* FAQ    * Search  * Register * Login 
Active topics
Unanswered topics

All times are UTC-06:00



Post new topic  Reply to topic  [ 4 posts ] 
Author Message
 Post subject: No sound effects D3 and Win7-64
PostPosted: Sat Feb 27, 2010 3:49 pm 
Offline
DBB Material Defender
DBB Material Defender
User avatar

Joined: Thu Oct 26, 2006 9:13 am
Posts: 4871
I know there's a thread around here somewhere concerning the 1.5 patch for D3, but I couldn't find it. That's probably the best place for this. I can hear music but no sound effects. I'm pretty sure at this point DX11 breaks D3's sound. If I run in XPMode I get sound in the setup menu so DX9 in a VM is working. I can't get past the setup screen because there is no video acceleration. Sure hope the 1.5 patch addresses this.


Top
   
 Post subject:
PostPosted: Sat Feb 27, 2010 4:40 pm 
Offline
DBB Database Master
DBB Database Master
User avatar

Joined: Sun Nov 29, 1998 3:01 am
Posts: 15146
ICQ: 46028958
Website: http://krom.d3k.org
AOL: dutenhnj
Location: Camping the energy center. BTW, did you know you can have up to 100 characters in this location box?
Descent3 uses directsound and that should be emulated by the OS, make sure all the playback devices are selected correctly in control panel and in d3 setup (been a while since I've used D3 setup, can't remember if it has options to pick the primary audio device).

I guess one of these days I should unpack D3 and fire it up on my W7 x64 box so I can help people sort out these issues.

Otherwise there is another workaround that I have used for other games that don't cooperate in Windows 7 x64: Sun VirtualBox. I've used a virtual machine running Windows XP in Sun VirtualBox with its experimental 3D support and had great success getting previously broken games to work again with Direct 3D acceleration (no OpenGL though).


Top
   
 Post subject:
PostPosted: Sat Feb 27, 2010 4:54 pm 
Offline
DBB Material Defender
DBB Material Defender
User avatar

Joined: Thu Oct 26, 2006 9:13 am
Posts: 4871
Hah after messing around in the control panel again, I found that if I set a NoSound windows theme and then start D3 I get no effects. If I enable sounds again, start D3, I have sound. Disable Windows sounds again in control panel and it works. Weird but I'm glad it's working now. Thanks for the help Krom.


Top
   
 Post subject:
PostPosted: Sat Feb 27, 2010 5:18 pm 
Offline
DBB Master
DBB Master
User avatar

Joined: Thu Nov 22, 2001 3:01 am
Posts: 9205
WLM: biffski@yahoo.com
Location: Beaverton, Oregon USA
I had some weird goings ons with D3 as well. ALchemy fixed it. W7 and Dx11 breaks a number of legacy stuff.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 4 posts ] 

All times are UTC-06:00


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  



Descent'rs have piloted these pages
 
The layout and contents contained within this site are © DescentBB.net 1997-2006.
Descent, Descent II are © Parallax Software Corporation.
Descent III is Outrage Entertainment.
Descent is a Trademark of Interplay Productions.

Miner Wars™ is trademark of Keen Software House s. r. o.
.


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group