D1x Midi Music Question

A forum just for you old time Descent and Descent2 players.
Post Reply
User avatar
JohnnnY
DBB Ace
DBB Ace
Posts: 96
Joined: Mon May 24, 2004 5:56 pm
Contact:

D1x Midi Music Question

Post by JohnnnY » Sat Sep 11, 2004 9:53 am

Just a little question. When I play d1x, I notice that I get MIDI music. But the music only plays the music for the first seven levels and then it loops back over again to the song for level 1 on the 8th level. Is there a way to make it play all 22 songs?
User avatar
Kyouryuu
DBB Alumni
DBB Alumni
Posts: 5775
Joined: Fri Apr 30, 1999 2:01 am
Location: Isla Nublar
Contact:

Post by Kyouryuu » Sat Sep 11, 2004 1:07 pm

Some custom mission packs overwrite the DESCENT.SNG file. Have you installed any of those lately?
User avatar
JohnnnY
DBB Ace
DBB Ace
Posts: 96
Joined: Mon May 24, 2004 5:56 pm
Contact:

Post by JohnnnY » Sat Sep 11, 2004 2:53 pm

I dont remember. Will reinstalling d1 fix this problem?

I just looked thru my folder and I noticed that I do not have a descent.sng file there, is there a way to get it?
User avatar
Sirius
DBB Master
DBB Master
Posts: 5434
Joined: Fri May 28, 1999 2:01 am
Location: Bellevue, WA
Contact:

Post by Sirius » Sat Sep 11, 2004 4:48 pm

You won't do. It'll be in the descent.hog file.

In fact, if descent.sng is there and doesn't show all 22 songs, that's what is causing it.

I'm not sure whether having it in the missions folder (if you have a separate missions folder) would cause the same problem.

If you haven't loaded any mission other than the Descent 1 single-player campaign, the descent.sng file inside descent.hog will be the one that has been loaded. It's not impossible that that has been changed, although I think it's unlikely.

I haven't used D1x for some time and in fact can't run it in Windows XP due to incompatibility with its video system, so I'm not sure whether D1x itself has anything to do with this problem.

Reinstalling D1 -should- do it. If not, chances are D1x is involved.
User avatar
Top Gun
DBB Master
DBB Master
Posts: 7120
Joined: Wed Nov 13, 2002 3:01 am

Post by Top Gun » Sun Sep 12, 2004 12:06 pm

I've played D1X in XP before, and if I remember correctly, it normally handles the MIDI tracks fine. It probably does have to do with some other mission you've tried. If all else fails, install D1 to a different directory and try running it without any added mission files.
User avatar
JohnnnY
DBB Ace
DBB Ace
Posts: 96
Joined: Mon May 24, 2004 5:56 pm
Contact:

Post by JohnnnY » Mon Sep 13, 2004 4:29 pm

Ya, I just looked through the descent.sng file. It showed game01-game07.hmp, do I gotta type the other ones in?

Nvm I did that and now it works... doh.. lol.
MD-2389
Defender of the Night
Defender of the Night
Posts: 13452
Joined: Thu Nov 05, 1998 12:01 pm
Location: Olathe, KS

Post by MD-2389 » Mon Sep 13, 2004 7:19 pm

I don't suppose you ran the D1 1.0 -> 1.5 patch did you? If so, thats a known flaw in it. You have to patch to 1.4a and THEN to 1.5.
User avatar
Sirius
DBB Master
DBB Master
Posts: 5434
Joined: Fri May 28, 1999 2:01 am
Location: Bellevue, WA
Contact:

Post by Sirius » Tue Sep 14, 2004 12:14 am

Hmm.

I seem to remember something about that bug now.

Not that I ever had it, since the first version of D1 I picked up was Anniversary Edition, which came by default with either 1.4a or 1.5.
Post Reply