D2X-XL Bug Reports - MS Windows - continuation thread

D2X-XL - Descent II update for modern systems with many new features and enhanced graphics. Home Page

Moderators: Grendel, Aus-RED-5

Weyrman
DBB Ace
DBB Ace
Posts: 163
Joined: Thu Oct 06, 2005 5:40 pm
Location: Brisbane Australia

Post by Weyrman » Mon Jul 31, 2006 7:40 pm

ok problems with 1.6.124

loaded 2 savegames, both CTD
started new game CTD
loaded savegame game actually loaded but brightness is way down and keyboard and mouse non responsive
tried another savegame, same thing
went back to 1. 6.123 all is well
Pilot from Oz
User avatar
Diedel
D2X Master
D2X Master
Posts: 5278
Joined: Thu Nov 05, 1998 12:01 pm
Contact:

Post by Diedel » Tue Aug 01, 2006 4:54 am

Fixed.
User avatar
Larry
DBB Cadet
DBB Cadet
Posts: 15
Joined: Tue Oct 04, 2005 4:41 pm
Location: Koenigsbrunn

Secret Level Ending

Post by Larry » Wed Aug 02, 2006 2:59 pm

:? I played the first secret Level in the Descent1 Missions, but at the end the prog hung up because it was trying to find a \"level 0\"

that's the message at the end
Image

i used the switch -secretsave and loaded sometimes. Maybe that's a problem.
User avatar
Diedel
D2X Master
D2X Master
Posts: 5278
Joined: Thu Nov 05, 1998 12:01 pm
Contact:

Post by Diedel » Wed Aug 02, 2006 3:16 pm

Please send the savegame to karx11erx at hotmail dot com.
User avatar
Aus-RED-5
DBB Friend
DBB Friend
Posts: 1604
Joined: Fri Apr 23, 2004 7:27 am
Location: Adelaide, South Australia
Contact:

Post by Aus-RED-5 » Fri Aug 04, 2006 3:31 am

Version 1.6.128

Start any of the following options for IPX, UDP, UDP/IP, UDP/IP VIA Tracker, and UDP/IP Multicast game options.
Select any mission to host.
Start the game without a second player joining.
Mission loads and once you enter the mine it freezes and D2X-XL crashes. :(
Image

This even happens in Kali.

Anybody else get this? :?


::EDIT::

BTW, this happens when \"Improved UDP/IP Networking Quality\" is enabled.
User avatar
Diedel
D2X Master
D2X Master
Posts: 5278
Joined: Thu Nov 05, 1998 12:01 pm
Contact:

Post by Diedel » Fri Aug 04, 2006 4:12 am

Ummm ... I fiddled around with UDP code recently ... but I didn't want to tell anybody. If my changes were alright, you wouldn't notice, and if not, you would tell me anyway ....


HAAAAAAAAAAAAAAAAAAAAAAAAAHAHAHAHAHAHA!

:P

But isn't it a nice treat of Microsoft to apologize on my behalf? :roll: :lol:

Edit: No problems here.
User avatar
Glowhyena
DBB Captain
DBB Captain
Posts: 621
Joined: Mon Feb 27, 2006 10:14 pm
Location: Chernobyl NPP
Contact:

Post by Glowhyena » Fri Aug 04, 2006 5:27 pm

Hey, what about my subtitles?
MD1985
User avatar
Diedel
D2X Master
D2X Master
Posts: 5278
Joined: Thu Nov 05, 1998 12:01 pm
Contact:

Post by Diedel » Sat Aug 05, 2006 2:04 am

Guess what, Jonathan? Someone else complained they were on when he had turned them off. Not joking.
User avatar
Aus-RED-5
DBB Friend
DBB Friend
Posts: 1604
Joined: Fri Apr 23, 2004 7:27 am
Location: Adelaide, South Australia
Contact:

Post by Aus-RED-5 » Sat Aug 05, 2006 2:19 am

That would have been me. :P

Funny enough I haven't checked to see if its still on or not. :roll:
User avatar
Diedel
D2X Master
D2X Master
Posts: 5278
Joined: Thu Nov 05, 1998 12:01 pm
Contact:

Post by Diedel » Sat Aug 05, 2006 3:02 am

Things still in the todo list:

- Joystick inversion flags reset when quitting and restarting game
- subtitles not working properly

Btw, purged my HD yesterday to get more space for a Linux partition and will install 64 bit Linux this weekend ... :mrgreen:
User avatar
Aus-RED-5
DBB Friend
DBB Friend
Posts: 1604
Joined: Fri Apr 23, 2004 7:27 am
Location: Adelaide, South Australia
Contact:

Post by Aus-RED-5 » Sat Aug 05, 2006 5:08 am

You're gonna love this one Diedel. :lol:

I've enabled movies (-nomovies 0) in the d2x.ini file and started D2X-XL v1.6.128.

The intro movie comes on and guess what?
Image
Thats right... Subtitles are still on. ^^^^

Even though I have turned them off.
Image

However, if I play the intro from the \"Play Movies\" Menu.
Image
Subtitles are turned off.

So this time I turned on Subtitles and played the intro movie from the \"Play Movies\" menu.
Subtitles are still off.

Funny how subtitles work at the start, but not when you watch the movies from the \"Play Movies\" menu. :P
User avatar
Diedel
D2X Master
D2X Master
Posts: 5278
Joined: Thu Nov 05, 1998 12:01 pm
Contact:

Post by Diedel » Sat Aug 05, 2006 11:10 am

Probably because the player file, which contains this settings, is only being read after playing the intro movies.
User avatar
Larry
DBB Cadet
DBB Cadet
Posts: 15
Joined: Tue Oct 04, 2005 4:41 pm
Location: Koenigsbrunn

Water Animation

Post by Larry » Mon Aug 07, 2006 9:54 am

hi,
I played a level with flowing water and everytime I loaded my savegame the water became faster :? why that
User avatar
Diedel
D2X Master
D2X Master
Posts: 5278
Joined: Thu Nov 05, 1998 12:01 pm
Contact:

Post by Diedel » Mon Aug 07, 2006 1:47 pm

Kabalist wrote: Hello!

In the single player D2 game on Level 21 D2XL crashes to desktop every time the quidebot command 'search for exit' is executed. The game crashes when I give the command from the guidebot menu and when the reactor is destroyed and the guidebot automatically begins to search for the exit as well. I am using version 1.6.130 but the problem occurs in every other version I've used also. I can go no farther in the game because of this bug. I'm using a home brew machine:

Motherboard is MSI 865PE Neo2-V with 2 Gigs of memory
Processor is Intel P4 3.4 GHz
OS is Windows XP home edition
Video card is ATI X800
Sound card is Creative X-Fi Platinum

So far I've only had this problem at Level 21 (Omega System 1: N'Nerj Ring). I have really enjoyed your D2-XL version up to this point. D2-XL is a real godsend for people like me who love the game but haven't been able to play it since we owned Voodoo 2 cards. I hope you can duplicate the problem so I can continue and finish the game.

auf wiedersehen!

Scott
User avatar
Diedel
D2X Master
D2X Master
Posts: 5278
Joined: Thu Nov 05, 1998 12:01 pm
Contact:

Post by Diedel » Mon Aug 07, 2006 1:49 pm

What? You can no farther? How about trying w/o Guidebot?

Please send me a savegame from short before destroying the reactor to karx11erx at hotmail dot com.
Kabalist
DBB Cadet
DBB Cadet
Posts: 4
Joined: Mon Jun 05, 2006 6:15 pm

What? You can no farther? How about trying w/o Guidebot?

Post by Kabalist » Tue Aug 08, 2006 7:37 am

[quote="Diedel"]What? You can no farther? How about trying w/o Guidebot?


He's such a nice little fellow, I can't imagine playing the game without him.
User avatar
Diedel
D2X Master
D2X Master
Posts: 5278
Joined: Thu Nov 05, 1998 12:01 pm
Contact:

Post by Diedel » Tue Aug 08, 2006 7:46 am

Actually, there seems to be a problem with Guidebot's path finding. :?

Edit:

This is an interesting problem. Actually, the GB leads you a path you should have opened before destroying the boss robot. As you didn't, it gets stuck in front of a grate that can be opened by operation a trigger somewhere in the level. Usually this is a hint to look for such a trigger, but in the special case of trying to exit the mine, this can be a fatal mistake if - like in your particular case - there is an unblocked path to the exit.
User avatar
Larry
DBB Cadet
DBB Cadet
Posts: 15
Joined: Tue Oct 04, 2005 4:41 pm
Location: Koenigsbrunn

Re: Water Animation

Post by Larry » Tue Aug 08, 2006 10:42 am

Larry wrote:hi,
I played a level with flowing water and everytime I loaded my savegame the water became faster :? why that
this problem is still there

Additionally, I played now Level 8 in D2 Singleplayer and I can go to the secret level for the second time. But I played it already in level 5. Maybe it's the same problem with the other system's secret levels, i didn't tested it yet
User avatar
Glowhyena
DBB Captain
DBB Captain
Posts: 621
Joined: Mon Feb 27, 2006 10:14 pm
Location: Chernobyl NPP
Contact:

Post by Glowhyena » Tue Aug 08, 2006 1:11 pm

Yeah, subtitles work in first movie only when run D2X-XL. Play Movie doesn't work. Very strange. :?
MD1985
User avatar
Diedel
D2X Master
D2X Master
Posts: 5278
Joined: Thu Nov 05, 1998 12:01 pm
Contact:

Re: Water Animation

Post by Diedel » Tue Aug 08, 2006 1:42 pm

Larry wrote:this problem is still there
Your donation still hasn't arrived. :P
Larry wrote:Additionally, I played now Level 8 in D2 Singleplayer and I can go to the secret level for the second time. But I played it already in level 5. Maybe it's the same problem with the other system's secret levels, i didn't tested it yet
Did you destroy the reactor?
BugSeeker
DBB Cadet
DBB Cadet
Posts: 4
Joined: Mon Aug 07, 2006 2:35 pm

Post by BugSeeker » Wed Aug 09, 2006 5:59 am

You cannot select the spread if you have the helix and you cannot select the vulcan if you have the gauss... Am I the only one experiancing this, if not, i'm surprised it hasn't been fixed yet!
User avatar
Diedel
D2X Master
D2X Master
Posts: 5278
Joined: Thu Nov 05, 1998 12:01 pm
Contact:

Post by Diedel » Wed Aug 09, 2006 6:02 am

RTFM and the FAQ!
User avatar
Neumaennl
DBB Ace
DBB Ace
Posts: 185
Joined: Thu May 05, 2005 6:01 am
Location: Germany (Munich)
Contact:

Post by Neumaennl » Wed Aug 09, 2006 6:03 am

Read the manual - it's not a bug, it's a feature
just uncheck the right checkbox and you'll be able to select the weapons
User avatar
Aus-RED-5
DBB Friend
DBB Friend
Posts: 1604
Joined: Fri Apr 23, 2004 7:27 am
Location: Adelaide, South Australia
Contact:

Post by Aus-RED-5 » Wed Aug 09, 2006 6:45 am

BugSeeker wrote:You cannot select the spread if you have the helix and you cannot select the vulcan if you have the gauss... Am I the only one experiancing this, if not, i'm surprised it hasn't been fixed yet!
Its been posted before.
Well kinda, untill I removed it.
But I did post what I found out about that prob! :lol:

Linkage
BugSeeker
DBB Cadet
DBB Cadet
Posts: 4
Joined: Mon Aug 07, 2006 2:35 pm

Post by BugSeeker » Wed Aug 09, 2006 8:31 am

Well, it was the message \"You don't have the spread cannon!\" and \"You don't have the vulcan cannon!\" is what made me think it was a bug.

I guess I must of overlooked it the first time I looked at the FAQ.
User avatar
Kirby
DBB Ace
DBB Ace
Posts: 151
Joined: Thu Nov 03, 2005 7:27 pm

Post by Kirby » Wed Aug 09, 2006 2:06 pm

1.6.136

1) The guidebot is acting very strange. Sometimes it will stall for 10 seconds, then go back to searching normally for 1 minute, then stall for another 10 seconds, and on and on.....and by stalling I mean having it move very slowly in a straight line

2) Resolution menu is still buggy for me :P
User avatar
Diedel
D2X Master
D2X Master
Posts: 5278
Joined: Thu Nov 05, 1998 12:01 pm
Contact:

Post by Diedel » Wed Aug 09, 2006 2:22 pm

2) Fix the custom screen res setting by chosing a regular one or entering useful values for width and height.
User avatar
Aus-RED-5
DBB Friend
DBB Friend
Posts: 1604
Joined: Fri Apr 23, 2004 7:27 am
Location: Adelaide, South Australia
Contact:

Post by Aus-RED-5 » Wed Aug 09, 2006 5:14 pm

BugSeeker wrote:Well, it was the message "You don't have the spread cannon!" and "You don't have the vulcan cannon!" is what made me think it was a bug.

I guess I must of overlooked it the first time I looked at the FAQ.
Then you need to be more specific about the problem when posting it here.
We can't read or see what is happening on your screen.

Anyways, try the suggestion that Neumaennl said to do.
Then let us know if it did or did not work.
Thanks. ;)
User avatar
Diedel
D2X Master
D2X Master
Posts: 5278
Joined: Thu Nov 05, 1998 12:01 pm
Contact:

Post by Diedel » Thu Aug 10, 2006 5:26 am

Well, I admit that the error messages are a bit misleading.
User avatar
Larry
DBB Cadet
DBB Cadet
Posts: 15
Joined: Tue Oct 04, 2005 4:41 pm
Location: Koenigsbrunn

Re: Water Animation

Post by Larry » Thu Aug 10, 2006 7:26 am

Diedel wrote:
Larry wrote:this problem is still there
Your donation still hasn't arrived. :P
Larry wrote:Additionally, I played now Level 8 in D2 Singleplayer and I can go to the secret level for the second time. But I played it already in level 5. Maybe it's the same problem with the other system's secret levels, i didn't tested it yet
Did you destroy the reactor?
donation? I'm a poor dog and only 15 years old, i'm soorry :P

the laava/water bug: here is a video for you, maybe now you can see the problem better:


In the secret level I destroyed the Reactor. But i still could go to this secret level in the other level of the System.
User avatar
Kirby
DBB Ace
DBB Ace
Posts: 151
Joined: Thu Nov 03, 2005 7:27 pm

Post by Kirby » Thu Aug 10, 2006 7:51 am

Diedel wrote:2) Fix the custom screen res setting by chosing a regular one or entering useful values for width and height.
I was talking about the "Cannot set requested mode on this video card" error :P Where it displays that error without allowing me to set a resolution first
User avatar
Diedel
D2X Master
D2X Master
Posts: 5278
Joined: Thu Nov 05, 1998 12:01 pm
Contact:

Post by Diedel » Thu Aug 10, 2006 7:57 am

Kirby,

it is very nice that it only takes so few posts to make you create a useful error description. You could extend the period of nice chit chat with just posting 'something doesn't work here' next time. :P

Get v1.6.138 and set a default resolution in d2x.ini (like '-640x480'). That should allow you to enter the screen res menu again and chose some valid screen res.

Larry,

you didn't get my point. :P I do not jump up and rush to my computer to fix it every time a D2X-XL user reports a bug or a problem. I have priorities. ;)

I don't want a movie. Send me a save game please (to karx11erx at hotmail dot com).

The secret level problem description is too unprecise for me to do anything about it, and my magic glass ball currently is defunct (software upgrade :P).
User avatar
Larry
DBB Cadet
DBB Cadet
Posts: 15
Joined: Tue Oct 04, 2005 4:41 pm
Location: Koenigsbrunn

Post by Larry » Thu Aug 10, 2006 1:00 pm

There is nothing with the save game, I can start a new level and save/load, still the same thing. If you have to do other things, there is no problem. I just want to tell you that flowing lava and water becomes faster after every loading. So remember this, and look after it if you have time. Nothing more :wink:

i know this is not really important, but it looks just bad while you play. Take your time you want ;)

plus you don't need any Magic Glass ball :P maybe I only have to describe it entirely:

Every system has its own secret level. And there are always 2 secret Teleporters. In the Quartzon system, in Level 5 and 8. I played when I was in Level 5 the secret level and destroyed the Reactor. Then in Level 8 i found the second Teleporter, but not as normally in the \"Original\" D2 i could play the secret level again. In the original Version, there would be a message now that the secret Level is already destoyed.

That's it ;)
User avatar
Diedel
D2X Master
D2X Master
Posts: 5278
Joined: Thu Nov 05, 1998 12:01 pm
Contact:

Post by Diedel » Thu Aug 10, 2006 2:02 pm

Oops @ secret level problem.

Please send me a save game showing the water problem. I cannot reproduce it.
Kabalist
DBB Cadet
DBB Cadet
Posts: 4
Joined: Mon Jun 05, 2006 6:15 pm

Thanks for Looking at My Problem!

Post by Kabalist » Thu Aug 10, 2006 3:37 pm

[quote="Diedel"]Actually, there seems to be a problem with Guidebot's path finding. :?

I hadn't looked at the board or the latest game revisions for a few days, but today I saw a fix that sounds like it addresses the problem I brought up. I'll update my copy of D2 with the latest revision and try it out.

Vielen Dank!

Scott
User avatar
Kirby
DBB Ace
DBB Ace
Posts: 151
Joined: Thu Nov 03, 2005 7:27 pm

Post by Kirby » Thu Aug 10, 2006 8:29 pm

Diedel wrote:Kirby,

it is very nice that it only takes so few posts to make you create a useful error description. You could extend the period of nice chit chat with just posting 'something doesn't work here' next time. :P
I am a computer science major....too bad I really can't do much now in fixing the actual problems :P

K...unnecessary chitchat next time :wink:

on the topic of that resolution error....I had -1280x1024 in my INI file this whole time....tried the 1.6.140 release too with no luck
User avatar
Diedel
D2X Master
D2X Master
Posts: 5278
Joined: Thu Nov 05, 1998 12:01 pm
Contact:

Post by Diedel » Fri Aug 11, 2006 1:34 am

Then you will have to crate a new player and use that one.
User avatar
Glowhyena
DBB Captain
DBB Captain
Posts: 621
Joined: Mon Feb 27, 2006 10:14 pm
Location: Chernobyl NPP
Contact:

Post by Glowhyena » Fri Aug 11, 2006 11:24 am

If playin' D2X-XL, press pause button and go to option Menu then close the option menu to back the game. The animat bugs are fastest how long the option menu displayed on the game.
MD1985
User avatar
Larry
DBB Cadet
DBB Cadet
Posts: 15
Joined: Tue Oct 04, 2005 4:41 pm
Location: Koenigsbrunn

Guide Bot Bug

Post by Larry » Fri Aug 11, 2006 12:17 pm

hi ,
in level 16 the Guide-Bot wants to find a Marker 1, instead of the Boss after i collected the Red Key. I'll send you the save game again...
User avatar
Diedel
D2X Master
D2X Master
Posts: 5278
Joined: Thu Nov 05, 1998 12:01 pm
Contact:

Post by Diedel » Fri Aug 11, 2006 1:41 pm

Jonathan Paskiewicz wrote:If playin' D2X-XL, press pause button and go to option Menu then close the option menu to back the game. The animat bugs are fastest how long the option menu displayed on the game.
That's not the bug we were talking about.
Locked