DescentBB
http://www.descentbb.net/

D2X-XL Bug Reports - MS Windows
http://www.descentbb.net/viewtopic.php?f=34&t=5893
Page 62 of 65

Author:  CP5670 [ Tue Apr 18, 2006 12:56 am ]
Post subject: 

I have been getting a strange crashing problem with D2X-XL for some time now. If I minimize (alt-tab) D2X-XL at any time and try to maximize it again, I instantly get a BSOD and my computer self-reboots. Is this a known problem? It doesn't occur in any other game I have. Also, this is not an issue on my laptop, so it seems to be something specific to certain hardware/driver configurations.

Author:  Diedel [ Tue Apr 18, 2006 1:51 am ]
Post subject:  Re:

Grendel wrote:
Same thing w/ 1.6.27 and all data files reloaded

We're getting closer, huh? :lol:

v1.6.28 with more log messages available. Some problem when reading the Descent 1 data, it seems. You can try to delete descent.pig from your D2 installation, but if you don't I might be able to figure what is going wrong here. ;)

CP5670,

I have noticed that D2X-XL often won't maximize again after alt+tabbing out of it, but no BSODs.

Author:  Aus-RED-5 [ Tue Apr 18, 2006 2:47 am ]
Post subject: 

2 bugs in version 1.6.27.

1) Light Maps are messed up in this verion. Was fine in the last version.
Image

2) Get close to the first door in CS and fire your lasers. Keep shooting through the door. You should see that the lasers dissapear near, around and through the door.
Image

Author:  PKMaestro [ Tue Apr 18, 2006 2:57 am ]
Post subject: 

v1.6.27: the game crashes when trying to enter Advanced Render Options, after activating Show Expert Options in Miscellaneous section. This problem happens only when using a player file created with an older version of D2X-XL.

Author:  Weyrman [ Tue Apr 18, 2006 4:50 am ]
Post subject: 

My copy of 1.6.27 doesn't do this
PKMaestro wrote:
the game crashes when trying to enter Advanced Render Options, after activating Show Expert Options in Miscellaneous section. This problem happens only when using a player file created with an older version of D2X-XL.


but it does have a sound problem. 1 particular sound sounds like br-r-r-r-r-r-r-r-r-r when you are supposed to hear it. whatever it is activates at the correct proximity to its trigger as it comes and goes as you move in certain spaces.


I also had a hostage that looked like he was swimming slowly up and through the roof.

The thiefbot would disappear and re-appear, not take damage and seem to not notice me, all in a particular area. In the level before though it was fine.

I am currently parked in front of a robot according to the map but nothing is there nor does anything attack me, nor can I shoot anything.

A savegame at this point is available. vertigo Lvl 2

Q. what are the ?secret.sgc files????

Author:  Diedel [ Tue Apr 18, 2006 12:09 pm ]
Post subject: 

When you enter a secret level, D2 stores the return point in the originating level in a sgc file.

Unfortunately I cannot reproduce any of your floating away items bugs. Please post the new savegame anyway.

Author:  Grendel [ Wed Apr 19, 2006 12:09 am ]
Post subject: 

1.6.29 -- still hanging but interesting log :)

d2x.log wrote:
Initializing game fonts
Initializing movies
Initializing game data
Loading game data
Loading main ham file
Loading 910 texture indices
Loading 254 sound indices
Loading 107 animation clips
Loading 105 animation descriptions
Loading 51 wall animations
Loading 66 robot descriptions
Loading 1145 robot joint descriptions
Loading 62 weapon descriptions
Loading 48 powerup descriptions
Loading 166 polymodel descriptions
Loading polymodel data
Loading 100 cockpit gauges
Loading 600 object bitmap indices
Loading player ship description
Loading 6 cockpit bitmaps
Loading 7 reactor descriptions
Loading bitmap index translation table
Looking for Descent 1 data files
Loading Descent 1 data
Loading 800 texture indices
Loading 800 texture descriptions
Initializing 250 sounds
Loading 842032505 animation clips
Loading 842032505 animation descriptions
Loading 21514823 wall animations
Loading -468237294 robot descriptions
Acquiring model data size of -909588024 polymodels

Author:  Diedel [ Wed Apr 19, 2006 1:00 am ]
Post subject: 

Grendel,

your Descent.pig seems whacked. See your PM.

Author:  CP5670 [ Wed Apr 19, 2006 11:48 am ]
Post subject:  Re:

Diedel wrote:
CP5670,

I have noticed that D2X-XL often won't maximize again after alt+tabbing out of it, but no BSODs.


On further investigation, it looks like this may be related to the Geforce 7 video cards in some way (I forgot to mention that it occurs in FS2 as well). See my post here:

http://www.hard-light.net/forums/index. ... #msg802659

Does anyone here have one of these cards and can reproduce these crashes?

Author:  Grendel [ Wed Apr 19, 2006 5:13 pm ]
Post subject:  Re:

Diedel wrote:
Grendel,

your Descent.pig seems whacked. See your PM.

I'll see to that in the evening. The same data was working w/ d2x-w32 tho..

Author:  Diedel [ Wed Apr 19, 2006 5:52 pm ]
Post subject: 

Does it still work with D2X-W32? Because data files can get corrupted, too ...

Author:  Grendel [ Wed Apr 19, 2006 6:14 pm ]
Post subject: 

I don't know -- I delete all older versions. This happened to me the 1st time I loaded 1.5.146. I did restore the D1 files along w/ the D2 files when you where requesting it tho.

Author:  Diedel [ Thu Apr 20, 2006 2:00 am ]
Post subject: 

Hm ... I had changed D1 data handling sometime ago ... maybe a bug crept in there, or your data isn't fully patched - there was a format change in the D1 data once.

Author:  Deathhand [ Thu Apr 20, 2006 9:17 am ]
Post subject: 

V1.6.28 Windows-Version

the keyboard ramping amount does not save and resets to 50% on every restart or levelchange.

Author:  Diedel [ Thu Apr 20, 2006 10:01 am ]
Post subject: 

Please create a new player file and see whether it works then.

Author:  Neumaennl [ Thu Apr 20, 2006 10:30 am ]
Post subject: 

I just can't get HiRez-textures to work - the weird thing is: I shared the D2X-XL folder on the LAN and accessed it from my brother's Laptop, so it's the same forlders, the same files, the same settings and guess what - it works! He's got an ATI Radeon mobility and I've got a GeForce 4 Ti 4200 - I can't imagine why it doesn't work - I can't believe the graphics card isn't capable of displaying the HiRez textures - Unreal Tournament 2004 for example works like a charm

btw: I also got the latest drivers, of course

Author:  Diedel [ Thu Apr 20, 2006 11:51 am ]
Post subject: 

May be because of the shader programs - although they should work like a breeze on a Ti 4200. Try to run with -printlog switch and check d2x.log for what it says about shaders. You can run them using -gl_alttexmerge 0, but then I recommend turning texture quality down from 'very high' (512x512) to 'high' (256x256), because D2X-XL will create a new texture for each frame each animated texture.

Author:  Grendel [ Thu Apr 20, 2006 10:55 pm ]
Post subject: 

Alright, 1.6.30 w/ a replaced DESCENT.PIG & DESCENT.HOG now works :)

For some reason the Y axis on my joystick is very unresponsive (ship moves barely up/down) and I didn't find a way to adjust it. Any ideas ?

Author:  Aus-RED-5 [ Fri Apr 21, 2006 1:59 am ]
Post subject:  Re:

Grendel wrote:
Alright, 1.6.30 w/ a replaced DESCENT.PIG & DESCENT.HOG now works :)

For some reason the Y axis on my joystick is very unresponsive (ship moves barely up/down) and I didn't find a way to adjust it. Any ideas ?


Yep.. Make sure expert options is enabled.
Then go into controls to set joy settings.
Image
Image

Author:  Diedel [ Fri Apr 21, 2006 2:53 am ]
Post subject: 

Grendel,

you can desync joy axes adjustment in the control settings dialog, and if you do that, specify different sensitivities for the first four joy axes (if your stick has more axes, sensitivities will be assigned round robin to them, i.e. axis <- sens 1, axis 6 <- sens 2, etc.).

Author:  Neumaennl [ Fri Apr 21, 2006 5:35 am ]
Post subject: 

v1.6.30: D2X-XL quits (SDL parachute deployed) when trying to enter Advanced Rendering Options

still no luck with HiRez textures

here's the log:

Loading program arguments
E:\\D2X-XL\\d2x-xl.exe
-printlog
-fullscreen
-grabmouse
-sound22k
-gl_alttexmerge 0
-playermessages
-noredundancy
-gl_reticle 0
-shortpackets
-pps 10
-player Martin
-render2texture 1
-menustyle 1
-fastmenus 1
-sdl_mixer 1
-use_d1sounds 1
-hires_textures 1
-hires_models 1
-mathformat 2
-printlog
GetAppFolder ('E:\\D2X-XL', '', 'data', 'descent2.hog')
GetAppFolder (data) = 'E:\\D2X-XL/data' (0)
expected game app folder = 'E:\\D2X-XL'
expected game data folder = 'E:\\D2X-XL/data'
GetAppFolder ('E:\\D2X-XL', 'E:\\D2X-XL/models', 'models', '*.oof')
GetAppFolder (models) = 'E:\\D2X-XL/models' (0)
GetAppFolder ('E:\\D2X-XL', 'E:\\D2X-XL/textures', 'textures', '*.tga')
GetAppFolder (textures) = 'E:\\D2X-XL/textures' (0)
GetAppFolder ('E:\\D2X-XL', 'E:\\D2X-XL/profiles', 'profiles', '')
GetAppFolder (profiles) = 'E:\\D2X-XL/profiles' (0)
GetAppFolder ('E:\\D2X-XL', 'E:\\D2X-XL/movies', 'movies', '*.mvl')
GetAppFolder (movies) = 'E:\\D2X-XL/movies' (0)
GetAppFolder ('E:\\D2X-XL', 'E:\\D2X-XL/savegames', 'savegames', '')
GetAppFolder (savegames) = 'E:\\D2X-XL/savegames' (0)
GetAppFolder ('E:\\D2X-XL', 'E:\\D2X-XL', 'screenshots', '')
GetAppFolder (screenshots) = 'E:\\D2X-XL' (1)
GetAppFolder ('E:\\D2X-XL', 'E:\\D2X-XL/demos', 'demos', '')
GetAppFolder (demos) = 'E:\\D2X-XL/demos' (0)
GetAppFolder ('E:\\D2X-XL', 'E:\\D2X-XL/config', 'config', '*.cfg')
GetAppFolder (config) = 'E:\\D2X-XL/config' (0)
Creating default tracker list
Loading main hog file
Loading text resources
File 'descent.tex' not found
Loading hires models
Loading ban list
File 'banlist.txt' not found
Initializing i/o
Reading configuration file
File 'descentw.cfg' not found
Initializing control types
Initializing joystick
Initializing graphics
Shaders are available
No rendering to texture available
building lightmap shader programs
Couldn't compile fragment shader
building texturing shader programs
Initializing render buffers
Loading default palette
Initializing game fonts
Initializing movies
Initializing game data
Loading game data
Loading main ham file
Loading 910 texture indices
Loading 254 sound indices
Loading 107 animation clips
Loading 105 animation descriptions
Loading 51 wall animations
Loading 66 robot descriptions
Loading 1145 robot joint descriptions
Loading 62 weapon descriptions
Loading 48 powerup descriptions
Loading 166 polymodel descriptions
Loading polymodel data
Loading 100 cockpit gauges
Loading 600 object bitmap indices
Loading player ship description
Loading 6 cockpit bitmaps
Loading 7 reactor descriptions
Loading bitmap index translation table
Looking for Descent 1 data files
Loading Descent 1 data
Loading 800 texture indices
Loading 800 texture descriptions
Initializing 250 sounds
Loading 0 animation clips
Loading 0 animation descriptions
Loading 26 wall animations
Loading 24 robot descriptions
Acquiring model data size of 78 polymodels
Loading sound data
Initializing sound data
Loading sound file
Loading sound data (183 sounds)
Loading sound data
Initializing endlevel data
Initializing sound
Loading hoard data
File 'intro.tex' not found
Initializing texture merge buffer
Setting screen mode
Loading player profile
building lightmap shader programs
Couldn't compile fragment shader
building texturing shader programs
File 'orderd2.pcx' not found
File 'menubg.tga' not found
File 'E:\\D2X-XL/missions/D2CHAOS.rdl' not found
File 'E:\\D2X-XL/missions/D2-2PLYR.rdl' not found
File 'E:\\D2X-XL/missions/emtombz.rdl' not found
File 'E:\\D2X-XL/missions/g-house.rdl' not found
File 'E:\\D2X-XL/missions/KAK.rdl' not found
File 'E:\\D2X-XL/missions/KOOLKAVE.rdl' not found
File 'E:\\D2X-XL/missions/KOOLKAV2.rdl' not found
File 'E:\\D2X-XL/missions/MAGNCORE.rdl' not found
File 'E:\\D2X-XL/missions/WSHOCK20.rdl' not found
File 'E:\\D2X-XL/missions/D2X.rdl' not found
File 'E:\\D2X-XL/missions/PANIC.rdl' not found
File 'E:\\D2X-XL/missions/CHAOS.rl2' not found
File 'E:\\D2X-XL/missions/COMDELUX.rl2' not found
File 'E:\\D2X-XL/missions/CORR11.rl2' not found
File 'E:\\D2X-XL/missions/DEMONBRG.rl2' not found
File 'E:\\D2X-XL/missions/DETHPOST.rl2' not found
File 'E:\\D2X-XL/missions/DUALITY.rl2' not found
File 'E:\\D2X-XL/missions/ERTHSTRK.rl2' not found
File 'E:\\D2X-XL/missions/FBOMEGA.rl2' not found
File 'E:\\D2X-XL/missions/HUMIL2.rl2' not found
File 'E:\\D2X-XL/missions/LUNAPOST.rl2' not found
File 'E:\\D2X-XL/missions/MAD.hog' not found
File 'E:\\D2X-XL/missions/MAD.hog' not found
File 'E:\\D2X-XL/missions/MAG4.rl2' not found
File 'E:\\D2X-XL/missions/NEWEST.hog' not found
File 'E:\\D2X-XL/missions/NEWEST.hog' not found
File 'E:\\D2X-XL/missions/OBSRV13.rl2' not found
File 'E:\\D2X-XL/missions/RETRIB11.hog' not found
File 'E:\\D2X-XL/missions/RETRIB11.hog' not found
File 'E:\\D2X-XL/missions/SERENITY.rl2' not found
File 'E:\\D2X-XL/missions/SUPER_S.rl2' not found
File 'E:\\D2X-XL/missions/TERMINUS.rl2' not found
File 'E:\\D2X-XL/missions/TRANQUIL.rl2' not found
File 'robot.tex' not found
Loading level...
unloading cambot
unloading additional models
unloading additional model textures
restoring default robot settings
Destroying camera objects
Destroying smoke objects
Initializing smoke manager
loading level 'd2leva-1.rl2'
loading palette
loading level data
File 'd2leva-1.pal' not found
loading level textures
loading replacement textures
File 'd2leva-1.pog' not found
loading endlevel data
File 'd2leva-1.END' not found
File 'd2leva-1.txb' not found
loading cambot
loading replacement robots
File 'd2leva-1.hxm' not found
initializing cambot
counting entropy rooms
gathering CTF+ flag goals
initializing door animations
initializing sound sources
rebuilding OpenGL texture data
building lightmap shader programs
Couldn't compile fragment shader
building texturing shader programs
File 'orderd2.pcx' not found
Saving configuration file
Saving player profile
Releasing tracker list

Author:  Diedel [ Fri Apr 21, 2006 6:13 am ]
Post subject: 

Your gfx card doesn't like lightmapping fragment shaders, but the texture shaders are ok, so I don't know why that shouldn't work.

Please also create a new player and see whether advanced render options and hires textures work with that one.

Author:  VR7 [ Sun Apr 23, 2006 6:38 pm ]
Post subject: 

1.6.32
- Coloured lights have become a mess.
- Oh, and hires textures still don't work for me, even with a new player file.

Author:  Weyrman [ Tue Apr 25, 2006 4:51 am ]
Post subject: 

1.6.33

no Hi-res, stepped back to .32 .31, (.exe only) no hi-res in any version.

Doors open and close in response to weapons/flares but once you pass through and then open it from the other side, the door then remains open: D2 Counterstrike level 1

Created new player, no difference

Author:  Aus-RED-5 [ Tue Apr 25, 2006 5:19 am ]
Post subject:  Re:

Weyrman wrote:
1.6.33

no Hi-res, stepped back to .32 .31, (.exe only) no hi-res in any version.

Hires works for me.

Did you check to make sure that in your render options that its set to "highest"?

Weyrman wrote:
Doors open and close in response to weapons/flares but once you pass through and then open it from the other side, the door then remains open: D2 Counterstrike level 1

The door prob happens the same way for me too. :(

Author:  Diedel [ Tue Apr 25, 2006 5:56 am ]
Post subject: 

Fixed it already. Wait for 1.6.34. ;)

I need a savegame for the floating away objects bug, preferrably one with an object really far away like in Weyrman's case.

Author:  Deathhand [ Tue Apr 25, 2006 1:16 pm ]
Post subject:  Keyboard ramping still not saved

Version 1.6.34

As explained above, keyboard ramping still sticks on 50% after level change or start playing singleplayer.

Tested it with newly created Pilot, still the same.

Author:  Diedel [ Tue Apr 25, 2006 1:34 pm ]
Post subject: 

Deathhand,

I am sorry but I cannot reproduce that, so I cannot fix it. This doesn't mean I don't believe you, just that I cannot nail this bug down.

Author:  Weyrman [ Tue Apr 25, 2006 1:56 pm ]
Post subject: 

1.6.34

Doors working fine now

keyboard ramping fine (just a note)

still no hi-res wall textures but hi polymodel ship shows ok

Author:  Diedel [ Tue Apr 25, 2006 3:12 pm ]
Post subject: 

Weyr,

did you post a debug log here already once because of the hires texture problem? I don't remember ...

Hires pyro and wall texture handling are not related code-wise.

Author:  Xamindar [ Tue Apr 25, 2006 9:37 pm ]
Post subject: 

I made a folder titled \"d2x-xl\" and put the files in there. It didn't work. Then I renamed it to \"d2xxl\" and it worked.

Also, I am not able to change my joystick sensitivity. It just goes back to the left side when I leave the menu. What is stoping my joystick settings from being saved.

Author:  Diedel [ Wed Apr 26, 2006 4:22 am ]
Post subject: 

My brother can't save his keyboard settings ... I am having none of these problems, on none of the 3 systems I use, be it with older or up to date player profiles ... :?

Author:  Aus-RED-5 [ Wed Apr 26, 2006 4:26 am ]
Post subject:  Re:

Diedel wrote:
My brother can't save his keyboard settings ... I am having none of these problems, on none of the 3 systems I use, be it with older or up to date player profiles ... :?

Maybe a "fresh" install from the D2 CD is needed to find the probs? :?:

Author:  Diedel [ Wed Apr 26, 2006 4:40 am ]
Post subject: 

I don't think that's the problem here.

Author:  Aus-RED-5 [ Wed Apr 26, 2006 4:53 am ]
Post subject: 

You know?
The sad thing is I reported this back in March.

Page 57: Posted Sat Mar 18, 2006
http://www.descentbb.net/viewtopic.php?p=160481#160481

Page 57: Posted Sat Mar 19, 2006
http://www.descentbb.net/viewtopic.php?p=160589#160589

:(

Author:  Weyrman [ Wed Apr 26, 2006 5:06 am ]
Post subject: 

1.6.35 - Still no hi-res

Here is the debug log for the above attempt

d2x.log

Author:  Diedel [ Wed Apr 26, 2006 5:31 am ]
Post subject: 

What is telling you that you don't have hires textures?

Author:  Weyrman [ Wed Apr 26, 2006 6:27 am ]
Post subject: 

Previously, all the lights were DEFINITELY hi-res, sharp edges and frames, some wall textures and grills as well.

It is the first thing I look for with a new version, as I test with level 1 and the lights on either side of the start point shold be hi-res and are not.

Author:  Diedel [ Wed Apr 26, 2006 6:47 am ]
Post subject: 

Your system runs the shader programs and finds the hires texture folder. From the log file I cannot see a reason why it doesn't work on your machine.

What is your texture quality setting in advanced render options?

Author:  Aus-RED-5 [ Wed Apr 26, 2006 6:57 am ]
Post subject:  Re:

Aus-RED-5 wrote:
Did you check to make sure that in your render options that its set to "highest"?


I ask this too, But he did not reply. :roll:

Page 62 of 65 All times are UTC-06:00
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/