DescentBB
http://www.descentbb.net/

D2X-XL Bug Reports - MS Windows
http://www.descentbb.net/viewtopic.php?f=34&t=5893
Page 64 of 65

Author:  Diedel [ Tue May 02, 2006 5:52 am ]
Post subject: 

It seems to depend on the OpenGL ICD you are using. There was a guy from a Dutch Voodoo fan site around here a few months ago who I believe got it to work. A German V5500 user the name of which has escaped my memory afaik also runs D2X-XL on his V5500. Could be Zorc. Find him on the German DescentForum.

Author:  Aus-RED-5 [ Tue May 02, 2006 5:58 am ]
Post subject: 

You talkin about Obi-Wan Kenobi?

Yeah I remember him.

Not sure if he ever visits here anymore since this thread. :oops:

BTW. From memory. It was on WinXP with Voodoo5 5500 he got it to work on.

EDIT:
I take that back. :P
D2X-XL + Voodoo5 5500 & Win 98SE

Author:  Diedel [ Tue May 02, 2006 6:44 am ]
Post subject:  Re:

Aus-RED-5 wrote:
You talkin about Obi-Wan Kenobi?

Exactly. :)

Author:  d3jake [ Tue May 02, 2006 5:29 pm ]
Post subject:  Re:

Diedel wrote:
Double clicked what?

the D2X-XL icon
Quote:
Do you manually select a player profile, or have you specified one in d2x.ini?

it's set to come up manually
Quote:
Have you come so far to see the main menu and tried to start a game, or not?

Nope, it doesn't get that far. It will bring up the D2 load screen for a second or two, then close right back down again.

My video card is a 3dfx Voodoo3, running the orginal drivers from the install disk that came with the card.

EDIT: I don't know what I did, but using this d2x.ini file:-fullscreen -grabmouse -sound22k -nocdrom -render_quality 3 -playermessages -noredundancy -nomovies 1 -shortpackets -pps 10 -640x480 -render2texture 1 -menustyle 0 -fastmenus 1
-sdl_mixer 1 -mathformat 2 -use_d1sounds 0 -altbg_brightness 0.75 -altbg_alpha -1.0 -altbg_grayscale 0 -hires_textures 1-hires_models 1
-printlog

I was able to reach a blank screen with the main D2 music playing (not the music I remember from D2...same thing but is sounds off) THen when I press ENTER it closes out again.

I'm not sure if it helps but here's the log file:
Loading program arguments
C:\\Games\\Descent2\\d2x-xl.exe
-grabmouse
-sound22k
-nocdrom
-render_quality 3
-playermessages
-noredundancy
-nomovies 1
-shortpackets
-pps 10
-player d3jake
-render2texture 1
-menustyle 0
-fastmenus 1
-sdl_mixer 1
-mathformat 2
-use_d1sounds 1
-altbg_brightness 0.75
-altbg_alpha -1.0
-altbg_grayscale 0
-hires_textures 1
-hires_models 1
-printlog
GetAppFolder ('C:\\Games\\Descent2', '', 'data', 'descent2.hog')
GetAppFolder (data) = 'C:\\Games\\Descent2' (1)
GetAppFolder ('C:\\Games\\Descent2', 'C:\\Games\\Descent2', 'data', 'd2demo.hog')
GetAppFolder (data) = 'C:\\Games\\Descent2' (1)
expected game app folder = 'C:\\Games\\Descent2'
expected game data folder = 'C:\\Games\\Descent2'
GetAppFolder ('C:\\Games\\Descent2', 'C:\\Games\\Descent2', 'models', '*.oof')
GetAppFolder (models) = 'C:\\Games\\Descent2' (1)
GetAppFolder ('C:\\Games\\Descent2', 'C:\\Games\\Descent2', 'textures', '*.tga')
GetAppFolder (textures) = 'C:\\Games\\Descent2' (1)
GetAppFolder ('C:\\Games\\Descent2', 'C:\\Games\\Descent2', 'profiles', '')
GetAppFolder (profiles) = 'C:\\Games\\Descent2' (1)
GetAppFolder ('C:\\Games\\Descent2', 'C:\\Games\\Descent2', 'movies', '*.mvl')
GetAppFolder (movies) = 'C:\\Games\\Descent2' (1)
GetAppFolder ('C:\\Games\\Descent2', 'C:\\Games\\Descent2', 'savegames', '')
GetAppFolder (savegames) = 'C:\\Games\\Descent2' (1)
GetAppFolder ('C:\\Games\\Descent2', 'C:\\Games\\Descent2', 'screenshots', '')
GetAppFolder (screenshots) = 'C:\\Games\\Descent2' (1)
GetAppFolder ('C:\\Games\\Descent2', 'C:\\Games\\Descent2/demos', 'demos', '')
GetAppFolder (demos) = 'C:\\Games\\Descent2/demos' (0)
GetAppFolder ('C:\\Games\\Descent2', 'C:\\Games\\Descent2', 'config', '*.cfg')
GetAppFolder (config) = 'C:\\Games\\Descent2' (1)
Creating default tracker list
Loading main hog file
found hog file 'd2x.hog'
found hog file 'd2x-xl.hog'
found hog file 'extra.hog'
found hog file 'descent.hog'
Loading text resources
File 'descent.tex' not found
Loading hires models
File 'pyrogl.oof' not found
Loading ban list
File 'banlist.txt' not found
Initializing i/o
Reading configuration file
File 'descentw.cfg' not found
Initializing control types
Initializing joystick
Initializing graphics
No shaders available
No rendering to texture available
building lightmap shader programs
Initializing render buffers
Loading default palette
Initializing game fonts
Initializing movies
found movie lib 'intro-h.mvl'
found movie lib 'other-h.mvl'
found movie lib 'robots-h.mvl'
File 'extra1-h.mvl' not found
File '.extra1-h.mvl' not found
File 'extra1-l.mvl' not found
File '.extra1-l.mvl' not found
File 'extra2-h.mvl' not found
File '.extra2-h.mvl' not found
File 'extra2-l.mvl' not found
File '.extra2-l.mvl' not found
File 'extra3-h.mvl' not found
File '.extra3-h.mvl' not found
File 'extra3-l.mvl' not found
File '.extra3-l.mvl' not found
File 'extra4-h.mvl' not found
File '.extra4-h.mvl' not found
File 'extra4-l.mvl' not found
File '.extra4-l.mvl' not found
File 'extra5-h.mvl' not found
File '.extra5-h.mvl' not found
File 'extra5-l.mvl' not found
File '.extra5-l.mvl' not found
Initializing game data
Initializing hash tables
Initializing sound data (254 sounds)
Initializing bitmap index (2620 indices)
Initializing placeholder bitmap
Loading game data
Loading main ham file
Loading 910 texture indices
Loading 254 sound indices
Loading 107 animation clips
Loading 105 animation descriptions
Loading 51 wall animations
Loading 66 robot descriptions
Loading 1145 robot joint descriptions
Loading 62 weapon descriptions
Loading 48 powerup descriptions
Loading 166 polymodel descriptions
Loading polymodel data
Loading 100 cockpit gauges
Loading 600 object bitmap indices
Loading player ship description
Loading 6 cockpit bitmaps
Loading 7 reactor descriptions
Loading bitmap index translation table
Looking for Descent 1 data files
File 'descent.pig' not found
Loading sound file
Loading sound data (183 sounds)
Loading sound data
Initializing endlevel data
Initializing sound
Loading hoard data
File 'intro.tex' not found
found hog file 'descent.hog'
File 'descent.sng' not found
Initializing texture merge buffer
Setting screen mode
File 'C:\\Games\\Descent2/sbenrgyb.tga' not found
File 'C:\\Games\\Descent2/gauge02b.tga' not found
Loading player profile
File 'orderd2.pcx' not found

(Should we continue this through PMs? Or should this conversation stay here?

Author:  Diedel [ Tue May 02, 2006 8:00 pm ]
Post subject: 

You need a good OpenGL wrapper for your gfx card. No wonder it doesn't work.

Author:  BUBBALOU [ Wed May 03, 2006 3:28 am ]
Post subject: 

I noticed no thread for a wishlist

-- commandline to specify redbook audio CDRom Drive for D2x-XL

D2 Setup sees the CDROM and plays the Redbook audio
Descent2.EXE sees CDROM Plays the Redbook Audio
D2_Win95(On XP compat mode) Does not
D2X-XL Does not

Author:  Aus-RED-5 [ Wed May 03, 2006 4:26 am ]
Post subject:  Re:

BUBBALOU wrote:
I noticed no thread for a wishlist

-- commandline to specify redbook audio CDRom Drive for D2x-XL

D2 Setup sees the CDROM and plays the Redbook audio
Descent2.EXE sees CDROM Plays the Redbook Audio
D2_Win95(On XP compat mode) Does not
D2X-XL Does not


D2X-XL suggestions thread is a wishlist.
Many have been posting for features there. ;)

Author:  Diedel [ Wed May 03, 2006 7:13 am ]
Post subject: 

You can enable redbook audio in the sound config menu.

Author:  d3jake [ Wed May 03, 2006 9:35 am ]
Post subject:  Re:

Diedel wrote:
You need a good OpenGL wrapper for your gfx card. No wonder it doesn't work.

could you suggest one?

Author:  Diedel [ Wed May 03, 2006 9:46 am ]
Post subject: 

No, sorry.

Author:  Neumaennl [ Wed May 03, 2006 10:14 am ]
Post subject: 

Diedel, you did an awesome Job on v1.6.44 - I finally got HiRez textures working and I got the D1 movies which just rock - my GF4 is kinda crapping its pants because of all the eye candy it has to compute now, but that's fine with me coz it looks SOOO beautiful

now would anybody PLEEEZE continue with the HiRez textures project? ;-)

the only flaw I noticed was that 100% white (255,255,255) is rendered black in the D1 movies (e.g. the lights above the screen in the 1st mission briefing) - seems like a palette bug - is that only on my machine?

Author:  Diedel [ Wed May 03, 2006 10:22 am ]
Post subject: 

It's a palette problem in the movie file. deuxsonic might fix it, but no promises.

Author:  Neumaennl [ Wed May 03, 2006 10:27 am ]
Post subject: 

does he already know about the problem? if not, could you tell him and ask for a fix?

Author:  d3jake [ Wed May 03, 2006 10:43 am ]
Post subject: 

So just google for \"OpenGL wrapper\"? I'll see what I can do. Strangely enough, there was a past version of D2X that I could get working, although the music wouldn't replay (it would stop after one time through) and would randomly shut down after a seemingly random period of time. Then if I started it up again it woudl a shorter time to shut down. I'll get the version number when I get home.

Author:  Diedel [ Wed May 03, 2006 1:46 pm ]
Post subject: 

I will not do anything to make D2X-XL work with a Win98+V2 machine.

Author:  BUBBALOU [ Wed May 03, 2006 2:30 pm ]
Post subject:  Re:

Diedel wrote:
You can enable redbook audio in the sound config menu.


by no means, am I an stranger to DESCENT2

Let me state it this WAY

;-nocdrom in d2x.ini REDBOOK = bug below
-nocdrom in d2x.ini NO REDBOOK = bug below

D2x-XL when you enable Redbook option it unchecks itself in half a second

Again

D2 Setup sees the CDROM and plays the Redbook audio
Descent2.EXE sees CDROM Plays the Redbook Audio

D2X-XL Does not

Author:  Diedel [ Wed May 03, 2006 3:36 pm ]
Post subject: 

Keep it polite.

Before I can look for a bug, I need a precise description incl. all settings made.

Edit: I have (hopefully) fixed the stuff. Don't have D2 redbook audio available though (Descent Definitive Collection D1+D2 CD doesn't seem to have the audio tracks). You can specify your music drive with the -cdrom switch.

Author:  CP5670 [ Wed May 03, 2006 4:52 pm ]
Post subject:  Re:

Diedel wrote:
Cannot reproduce. If you have checked high movie quality, uncheck it and see whether that helps.


I tried changing that but it makes no difference. It seems to occur at every resolution too. The other movies all work fine though.

I only have the high resolution movies installed, not the low res ones (the mve files with the -l suffix). Could it have something to do with that?

I can take a screenshot of the "smearing" effect if it will help any.

Author:  BUBBALOU [ Wed May 03, 2006 5:58 pm ]
Post subject: 

I am very polite

I have all 3 versions of Descent 2 on CD

Descent2
Descent 2 Infinite Abyss
Definitive Collection

and they all have redbook audio

I had this working before adding D1 into the D2X-XL directory asper your instructions at your website. I also did an update on the version of d2x-xl.

So process of elimination -- please add to the instructions at your site for D1 play on D2x-xl if you have DESCENT.CFG and move it to the Descent 2 directory rename the file to Descentbak.cfg or remove it entirely. the Root file OVERIDES the DATA folder one!!!

So the problem was not d2x-xl itself just vague instructions at the site for D1 play

CORRECTED ENJOY

there are 2 DESCENT.cfg files, one in each version of D1 and D2

BTW still no volume control for CD audio?

Author:  Diedel [ Thu May 04, 2006 1:59 am ]
Post subject: 

B,

If D2X-XL finds a config folder, it will look for descent.cfg there, and in no other folder (including the root game folder). It will never look for it in the data folder. You will not need the D1 descent.cfg file at all.

If you enable redbook audio, the midi volume slider label should be changed to CD volume (I changed that compared to other D2 versions, as D2X-XL can relabel existing menu controls, and it seems more elegant than to make one slider disappear and make another below the first appear).

If I put my original D1+D2 CD (from the pack containing D1+D2+D3+Merc) in my CD drive, I get an error message from SDL telling me something was wrong with the (one and only) audio track. When I try to open the audio track with MS Media Player, it doesn't find any audio tracks on it.

CP,

while the text is being printed, bot movies can be 'jumpy'. This should smooth once all text is there. I cannot reproduce the problem, so posting screens doesn't help, sorry.

Author:  BUBBALOU [ Thu May 04, 2006 3:16 am ]
Post subject:  Re:

Diedel wrote:
When I try to open the audio track with MS Media Player, it doesn't find any audio tracks on it.


WMP File/OPEN? .cda not listed

by default WMP will present you a DATA CD listing only the folders when the CD is mixed (not audio only)

So if you have WMP9/10 click RIP button (at top) menu, *.CDA tracks will be displayed and can be played.

Image

now "wave" and or "cd digital" will NO longer control the volume of the music being played,
only "cd audio" slider will control the volume under audio properties control panel (REDBOOK).
Also you must have the CD audio cable connected to the sound card from the CD Drive. or you will hear nada!!

Author:  Diedel [ Thu May 04, 2006 4:06 am ]
Post subject: 

I had tried WMP's rip music function, and it had displayed nothing for my CD (R/W) drive. I am pretty sure though that I don't have an audio connector cable attached to it. Have to try the DVD drive.

(Btw, printing in all capital letters is the digital equivalent to shouting. ;))

Author:  Aus-RED-5 [ Thu May 04, 2006 4:48 am ]
Post subject:  Re:

Diedel wrote:
I had tried WMP's rip music function, and it had displayed nothing for my CD (R/W) drive.
Image
Mine works! :P

Must be a German thing! j/k :lol:

Try clicking the "quick access panel" and select the drive the CD is in. Just an idea. :)

Author:  Neumaennl [ Thu May 04, 2006 5:09 am ]
Post subject: 

Diedel I think what you have is the \"Descent Venture Pack\"
I have it too - it contains D1, D2, D3 + merc
it has no Audio tracks on the CD - they are on the D1+D2 CD as MP3s
it also doesn't have the original installers for D1 + D2 - it has a Windows Installer which just copies the files to disk from an exe or cab file (instead of from a HOG file like the originals do IIRC)

I have the original D2 CD which contains Redbook Audio, too, although it is not in a very good condition
I'd try to make an ISO of it and give it to you if you want and have no other way of obtaining it
it would be a backup copy just available to you and therefore be legal coz you got the game already

Author:  Diedel [ Thu May 04, 2006 5:20 am ]
Post subject: 

Neumaennl,

sure, I'd appreciate that. At least I'd have something to test redbook audio with then. :)

I had several copies of D2 in my life, but I threw away at least three of them in a feeble attempt to get rid of what I classified as \"computer gaming addiction\" (particularly related to D2), until I finally gave up and stayed a happy computer gamer. :roll:

Author:  falcon4ever [ Sun May 07, 2006 12:30 pm ]
Post subject:  crash in multiplayergame

Does anyone expirience crashes when trying to use the multiplay mode?

I tried multiplaying with D2X-XL 1.6.49 on descent 2
using udp/ip (local) and with the tracker.

Imagine the following situation:
Host (using athlonxp 2700+ / Ati Radeon 9600 pro)
Client (using pentium-m 1.5 / Intel Extreme Graphics 2)
Using windows XP pro on both systems

The host setups a game an waits for people to join before starting the level. After the client joins, it will popup in the overview. Now the host decides to start the game.

In my case descent will crash on the client. The host will continue loading and go ingame. (after a few seconds a msg pops up \"you are the only person remaining in this netgame\"

If a client joins while the host is already ingame, the host will crash.

The strange thing is that Descent2 only crashes during this multiplayer. It works fine for single player mode.

i've turned on the logging function:
and zipped the logfile + d2x.ini of the host and client.
http://hosting.skyberate.net/~falcon4ever/d2x-xl/

Perhaps any of you got a clue why this happens?
:?

Author:  Diedel [ Sun May 07, 2006 1:17 pm ]
Post subject: 

Crash is confirmed; checking.

Edit: Fixed.

Author:  falcon4ever [ Sun May 07, 2006 2:34 pm ]
Post subject:  Re:

Diedel wrote:
Crash is confirmed; checking.

Edit: Fixed.


Thank you so much Diedel!

It works perfect now :D

Author:  Silencer [ Sun May 07, 2006 6:59 pm ]
Post subject: 

Hello! I recently updated to .49 from .6 (long story) and noticed that when I open doors in D2 there is what I can only describe as a blank white texture that you can't see through (apparently robots can though!), but you can fly through it. Everything else about the level is normal. This happens whether I start a save game or fresh new level. It happens with -gl_alttexmerge set to 1 (I use that since the lightmaps work better). I use an Nvidia 6800 GT with the latest reference drivers.

Author:  Diedel [ Mon May 08, 2006 1:53 am ]
Post subject: 

Fixed.

Author:  Silencer [ Mon May 08, 2006 4:44 am ]
Post subject: 

:o

Man, you rock!

If only support for retail games was this good... :(

Author:  Neumaennl [ Wed May 10, 2006 10:28 am ]
Post subject: 

D2X-XL 1.6.51 still crashes to the desktop
Quote:
Fatal signal: Segmentation Fault (SDL Parachute Deployed)

when trying to enter Advanced Render Options

Author:  Diedel [ Wed May 10, 2006 10:37 am ]
Post subject: 

Cannot reproduce.

Author:  Neumaennl [ Wed May 10, 2006 10:48 am ]
Post subject: 

maybe the printlog helps:

Loading program arguments
E:\\D2X-XL\\d2x-xl.exe
-printlog
-fullscreen
-grabmouse
-sound22k
-render_quality 3
-gl_alttexmerge
-playermessages
-noredundancy
-gl_reticle 0
-shortpackets
-pps 10
-player Martin
-render2texture 1
-menustyle 1
-fastmenus 1
-sdl_mixer 1
-mathformat 2
-use_d1sounds 1
-hires_textures 1
-hires_models 1
GetAppFolder ('E:\\D2X-XL', '', 'data', 'descent2.hog')
GetAppFolder (data) = 'E:\\D2X-XL/data' (0)
expected game app folder = 'E:\\D2X-XL'
expected game data folder = 'E:\\D2X-XL/data'
GetAppFolder ('E:\\D2X-XL', 'E:\\D2X-XL/models', 'models', '*.oof')
GetAppFolder (models) = 'E:\\D2X-XL/models' (0)
GetAppFolder ('E:\\D2X-XL', 'E:\\D2X-XL/textures', 'textures', '*.tga')
GetAppFolder (textures) = 'E:\\D2X-XL/textures' (0)
GetAppFolder ('E:\\D2X-XL', 'E:\\D2X-XL/profiles', 'profiles', '')
GetAppFolder (profiles) = 'E:\\D2X-XL/profiles' (0)
GetAppFolder ('E:\\D2X-XL', 'E:\\D2X-XL/movies', 'movies', '*.mvl')
GetAppFolder (movies) = 'E:\\D2X-XL/movies' (0)
GetAppFolder ('E:\\D2X-XL', 'E:\\D2X-XL/savegames', 'savegames', '')
GetAppFolder (savegames) = 'E:\\D2X-XL/savegames' (0)
GetAppFolder ('E:\\D2X-XL', 'E:\\D2X-XL', 'screenshots', '')
GetAppFolder (screenshots) = 'E:\\D2X-XL' (1)
GetAppFolder ('E:\\D2X-XL', 'E:\\D2X-XL/demos', 'demos', '')
GetAppFolder (demos) = 'E:\\D2X-XL/demos' (0)
GetAppFolder ('E:\\D2X-XL', 'E:\\D2X-XL/config', 'config', '*.cfg')
GetAppFolder (config) = 'E:\\D2X-XL/config' (0)
Creating default tracker list
Loading main hog file
found hog file 'd2x.hog'
found hog file 'd2x-xl.hog'
found hog file 'extra.hog'
found hog file 'descent.hog'
Loading text resources
File 'descent.tex' not found
Loading hires models
Loading ban list
File 'banlist.txt' not found
Initializing i/o
Reading configuration file
File 'descentw.cfg' not found
Initializing control types
Initializing joystick
Initializing graphics
Shaders are available
No rendering to texture available
building lightmap shader programs
Couldn't compile fragment shader
\"uniform sampler2D btmTex,topTex,lMapTex;float maxC,r,g,b;vec4 btmColor,topColor,lMapColor;void main(void){btmColor=texture2D(btmTex,vec2(gl_TexCoord[0]));topColor=texture2D(topTex,vec2(gl_TexCoord[1]));lMapColor=texture2D(lMapTex,vec2(gl_TexCoord[2]))+((gl_Color)-0.5);maxC=lMapColor.r;if(lMapColor.g>maxC)maxC=lMapColor.g;if(lMapColor.b>maxC)maxC=lMapColor.b;if(maxC>1.0){lMapColor.r/=maxC;lMapColor.g/=maxC;lMapColor.b/=maxC;}lMapColor.a = gl_Color.a;gl_FragColor = vec4(vec3(mix(btmColor,topColor,topColor.a)),(btmColor.a+topColor.a))*lMapColor;}\"
building texturing shader programs
Couldn't compile fragment shader
\"uniform sampler2D btmTex, topTex;vec4 btmColor, topColor;void main(void){topColor=texture2D(topTex,vec2(gl_TexCoord[1]));btmColor=texture2D(btmTex,vec2(gl_TexCoord[0]));gl_FragColor=vec4(vec3(mix(btmColor,topColor,topColor.a)),btmColor.a+topColor.a)*gl_Color;}\"
Initializing render buffers
Loading default palette
Initializing game fonts
Initializing movies
found movie lib 'intro-h.mvl'
found movie lib 'other-h.mvl'
found movie lib 'robots-h.mvl'
found movie lib 'extra1-h.mvl'
found movie lib 'extra2-h.mvl'
found movie lib 'extra3-h.mvl'
found movie lib 'extra4-h.mvl'
found movie lib 'extra5-h.mvl'
Initializing game data
Initializing hash tables
Initializing sound data (254 sounds)
Initializing bitmap index (2620 indices)
Initializing placeholder bitmap
Loading game data
Loading main ham file
Loading 910 texture indices
Loading 254 sound indices
Loading 107 animation clips
Loading 105 animation descriptions
Loading 51 wall animations
Loading 66 robot descriptions
Loading 1145 robot joint descriptions
Loading 62 weapon descriptions
Loading 48 powerup descriptions
Loading 166 polymodel descriptions
Loading polymodel data
Loading 100 cockpit gauges
Loading 600 object bitmap indices
Loading player ship description
Loading 6 cockpit bitmaps
Loading 7 reactor descriptions
Loading bitmap index translation table
Looking for Descent 1 data files
Loading Descent 1 data
Loading 800 texture indices
Loading 800 texture descriptions
Initializing 250 sounds
Loading 0 animation clips
Loading 0 animation descriptions
Loading 26 wall animations
Loading 24 robot descriptions
Acquiring model data size of 78 polymodels
Loading sound data
Initializing sound data
Loading sound file
Loading sound data (183 sounds)
Loading sound data
Initializing endlevel data
Initializing sound
Loading hoard data
Initializing texture merge buffer
Setting screen mode
File 'E:\\D2X-XL/textures/sbenrgyb.tga' not found
File 'E:\\D2X-XL/textures/gauge02b.tga' not found
Loading player profile
Invoking main menu
building lightmap shader programs
Couldn't compile fragment shader
\"uniform sampler2D btmTex,topTex,lMapTex;float maxC,r,g,b;vec4 btmColor,topColor,lMapColor;void main(void){btmColor=texture2D(btmTex,vec2(gl_TexCoord[0]));topColor=texture2D(topTex,vec2(gl_TexCoord[1]));lMapColor=texture2D(lMapTex,vec2(gl_TexCoord[2]))+((gl_Color)-0.5);maxC=lMapColor.r;if(lMapColor.g>maxC)maxC=lMapColor.g;if(lMapColor.b>maxC)maxC=lMapColor.b;if(maxC>1.0){lMapColor.r/=maxC;lMapColor.g/=maxC;lMapColor.b/=maxC;}lMapColor.a = gl_Color.a;gl_FragColor = vec4(vec3(mix(btmColor,topColor,topColor.a)),(btmColor.a+topColor.a))*lMapColor;}\"
File 'orderd2.pcx' not found
File 'menubg.tga' not found

Author:  Diedel [ Wed May 10, 2006 10:55 am ]
Post subject: 

it doesn't.

Author:  Neumaennl [ Wed May 10, 2006 11:05 am ]
Post subject: 

so there is nothing I or you can do about this?
I am a student of computer science, so I know how to work with a debugger, for example
if there's anything I can do, let me know

Author:  Diedel [ Wed May 10, 2006 12:18 pm ]
Post subject: 

Sure. Install the source code (D2X-XL, SDL, SDL_mixer) and debug it using MSVC 6 or .NET. You may want to use the Release settings, but turn code optimizations off (use the 'debug' optimizations settings, but not the 'debug' compile target), then the debugger should show the location of the crash.

Author:  Neumaennl [ Wed May 10, 2006 1:44 pm ]
Post subject: 

I'll try that tomorrow or at the weekend

I hope VS .NET 2005 can cope with the source code - I have to do some things with Direct3D and DirectShow for University and none of the examples work - it's frustrating, but it has to do with the crappy DirectX SDK which shouldn't affect D2X-XL

Author:  Neumaennl [ Wed May 10, 2006 1:48 pm ]
Post subject: 

d2x-xl-w32-1.6.52.zip contains the executable v1.6.51

Author:  reetus [ Wed May 10, 2006 8:24 pm ]
Post subject: 

the new cloak and invulnerability inventory thing is great but on d1 missions you have unlimited cloaks and invulnerabilities, is it supposed to be that way or only after you pick one up?

Page 64 of 65 All times are UTC-06:00
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/