DescentBB
http://www.descentbb.net/

D2X-XL Bug Reports - MS Windows
http://www.descentbb.net/viewtopic.php?f=34&t=5893
Page 65 of 65

Author:  Ferno [ Thu May 11, 2006 2:42 am ]
Post subject: 

It's only supposed to last 30 seconds.

Author:  Diedel [ Thu May 11, 2006 4:22 am ]
Post subject: 

reetus,

you mean you start with 255 cloaks and invuls? That would be a bug. I thought I had taken care of that ... :?

Edit: There is no cloak/invul inventory in D1 missions.

Author:  reetus [ Thu May 11, 2006 5:13 pm ]
Post subject: 

when I press Esc during a d1 mission it cloaks me, whether I've picked up a cloak or not. On the customize keyboard window I specified Q as use cloak and W as use invulnerability.I can press these any time during the game and it will cloak or make me invulnerable, whether I have picked one up or not.

Author:  Yogi [ Thu May 11, 2006 6:49 pm ]
Post subject:  Help!

I can't explain what happened. Yesterday I installed the newest 1.6.52 and started up D2. The in-game configurations were all changed and I was getting like 1 FPS! I re-configured the game and re-installed all files that are in my DATA folder and ROOT folder of descent. Now with good FPS, I do not have any mouse control. I can use the mouse to select menu items but can't use the mouse to control ship's pitch and yaw.

Before all this happened, I had no mouse issues at all. None. My mouse is a logitech MX510.

It's not my mouse driver because my mouse works in other apps.

EDIT: I have partial mouse control now. If mouse sensitivity is set to minimum, I get no mouse control at all. Now, I have pitch (PITCH U/D) control but no yaw like I used to have two days ago. Strange indeed.

:?
Yogi

Here's what my config.ini looks like:
-fullscreen
-grabmouse
-sound22k
-nocdrom
-1600x1200
-render_quality 3
-gl_alttexmerge
-use_shaders 1
-playermessages
-noredundancy
;use bitmap reticle
-gl_reticle 0
-shortpackets
;send 10 updates per second in multiplayer games
-pps 10
-player Yogi
-render2texture 1
-menustyle 1
-fastmenus 1
;set the following value to 0 to use Descent 2 sounds in Descent 1 levels
-use_d1sounds 1
-altbg_name menubg.tga
-altbg_brightness 0.75
-altbg_alpha -1.0
-altbg_grayscale 0
-hires_textures 0
-nomovies 0
-mathformat 2
-secretsave

Author:  Diedel [ Fri May 12, 2006 1:38 am ]
Post subject: 

I had added new keyboard controls for using cloaks and invuls, and that has messed up the player profile. Nothing I can do about it, the player profile file format is crap from the beginning. Reconfigure the mouse and you should be fine.

Author:  Neumaennl [ Fri May 12, 2006 4:03 am ]
Post subject: 

there seems to be something wrong with the lighting - D1 Level 1 shouldn't be this dark:

Image

in D2 Levels it's just the same...

in the movies list \"intro.mve\" appears twice, but \"final.mve\" does not appear

v1.6.52 messes up the autoselect ordering making all items laser cannon/concussion missle - this generates the error message \"weapon not in autoselect list\" when you pick up a weapon

Author:  Diedel [ Fri May 12, 2006 4:19 am ]
Post subject:  Re:

Neumaennl wrote:
there seems to be something wrong with the lighting

Contrast? (Advanced Render Options)

Neumaennl wrote:
in the movies list "intro.mve" appears twice, but "final.mve" does not appear

shrug

Neumaennl wrote:
v1.6.52 messes up the autoselect ordering making all items laser cannon/concussion missle - this generates the error message "weapon not in autoselect list" when you pick up a weapon

Oops.

Author:  Neumaennl [ Fri May 12, 2006 4:29 am ]
Post subject: 

got your talkative day, huh? :P

advanced render menu crashes again - could these uninitialized variables we were talking about stem from a corrupted *.plr file? (v1.6.52 corrupts the player file as mentioned before)

Author:  Diedel [ Fri May 12, 2006 5:17 am ]
Post subject: 

Well, it crashed before, didn't it?

You can do the following:

Put a LogErr (\"%s.%d\\n\", __FILE__, __LINE__); statement after every source line of the adv render options menu, same for the adv ropt menu callback function, run using -printlog and check the log file for the last line printed.

Author:  Neumaennl [ Fri May 12, 2006 6:01 am ]
Post subject: 

could be that the file was corrupted before, too - don't know how or why but could be

entered LogErr (\"%s.%d\\n\", __FILE__, __LINE__); several times but now it won't compile:

Fehler 77 error C2143: Syntaxfehler: Es fehlt ';' vor 'Typ' g:\\Dokumente und Einstellungen\\Martin\\Eigene Dateien\\Visual Studio 2005\\Projects\\D2X-XL\\main\\menu.c 1696

seems like the syntax of the line I pasted in isn't quite correct, but I'm quite sure I pasted the line in correctly and there is a semicolon before each int or the like (at least I can't find a place where a semicolon could be missing)

Author:  Diedel [ Fri May 12, 2006 6:18 am ]
Post subject: 

-> PM

Author:  Master Xan [ Sat May 13, 2006 9:25 pm ]
Post subject: 

Ok, as suggested/ordered/whatever, here's a report on my issue with doors. Running D2X-XL v 1.6.53, I can't see through doorways. Instead of 'open space' or a transparent wall/texture (not sure how the game handles it), I'm instead treated to a nice bit of blank wall, of the same texture as that next to the doorway. The doors all open as normal, and I can fly through what should be the opening (as well as fire through it or be hit by enemy fire). But not being able to see into a room before entering it is a major tactical disadvantage, and is causing me major headaches trying to play the game.

Here's a picture (link so as to help keep this post smaller). http://img.photobucket.com/albums/v286/ ... n/door.jpg

Looking at the picture, you should notice that 1) you can't see through the door, and 2) the door itself looks weird. Isn't there supposed to be more to the doorframe then that? Maybe its just my imagination, but I thought there should be a 'door' sort of color between the light and the actual door, rather then more of the red wall texture.

Author:  Aus-RED-5 [ Sat May 13, 2006 9:33 pm ]
Post subject:  Re:

Master Xan wrote:
Ok, as suggested/ordered/whatever, here's a report on my issue with doors. Running D2X-XL v 1.6.53, I can't see through doorways. Instead of 'open space' or a transparent wall/texture (not sure how the game handles it), I'm instead treated to a nice bit of blank wall, of the same texture as that next to the doorway. The doors all open as normal, and I can fly through what should be the opening (as well as fire through it or be hit by enemy fire). But not being able to see into a room before entering it is a major tactical disadvantage, and is causing me major headaches trying to play the game.

Here's a picture (link so as to help keep this post smaller).
Image

What switches are you using in the d2x.ini file?
Look for this one: -gl_alttexmerge.
If thats what it reads. Then add a 0 or 1 to the switch and see if that fix it.
It should look like this: -gl_alttexmerge 0 or -gl_alttexmerge 1.
Good luck. :)

Author:  Diedel [ Sun May 14, 2006 12:27 pm ]
Post subject: 

If at all, the problem should disappear when using '-gl_alttexmerge 0', because with that option every frame of a door animation (which consists of several images of the door in various stages of opening) is merged with the underlying texture (usually the door texture is put as an overlay to a wall texture to give it a solid frame), and a new merged texture is created for it. In this case, the special transparency handling for the door's interior is done when merging and not when rendering the texture - the problem shown happens when rendering the texture. I cannot reproduce it, neither with -gl_alttexmerge 0 nor 1 though.

Author:  Master Xan [ Sun May 14, 2006 2:23 pm ]
Post subject: 

Alright, that fixed it. My .ini file had '-gl_alttexmerge', without a 0 or 1. Placing a 0 at the end of the line fixed the problem nicely, thanks guys.

Author:  Diedel [ Sun May 14, 2006 3:06 pm ]
Post subject: 

Usually, if you omit a numerical argument to a cmd line switch, '1' is assumed (logic behind it: \"If the switch is present and not denied by adding '0', assume it's enforced\").

Author:  Master Xan [ Sun May 14, 2006 7:59 pm ]
Post subject: 

Ah, good to know. I'm not much of a programmer (as if you couldn't tell that already :roll: )

Author:  Weyrman [ Mon May 15, 2006 5:31 am ]
Post subject: 

Hey Diedel,

Cloak bug:

1.6.53
D1 Main Game.
SaveGame already existing when cloak and inv became inventory items.
Esc mapped as alternative cloak key.

Started a new level, saved the game and then hit Esc to exit out. As I did so, cloak went on and cloak inventory went from 0 to 255. Hmmm...

Dropped out, reloaded level, same thing.
Savegame, profile and log available on request

Author:  Aus-RED-5 [ Mon May 15, 2006 5:36 am ]
Post subject: 

I get the cloak bug every time I hit Esc - no matter what. :o

Author:  reetus [ Mon May 15, 2006 6:06 am ]
Post subject: 

Cloak and invulnerability at 255 when activated here also even when I uncheck the box for use inventory, on D1 missions. I also have trouble with it saving my settings, seems to uncheck the box for missle smoke trails and sound alarm when shield gets low. Everytime I start my game I have to check the box for missle smoke trails and uncheck the box for sound alarm.

Author:  Diedel [ Mon May 15, 2006 6:08 am ]
Post subject:  Re:

Master Xan wrote:
Ah, good to know. I'm not much of a programmer (as if you couldn't tell that already :roll: )

That has nothing to do with being a programmer. It's simply how I built it into D2X-XL. It can be different for other programs. ;)

Currently fixing cloak/invul bug, for real this time. :)

Author:  Tim [ Fri May 19, 2006 11:26 am ]
Post subject: 

DESCENT 4 MOVIE?? REALLY??? :oops: lol, see download section at descent2.de lol.

(probably wrong section to post in but I didn't see one for your website :wink: )

Author:  Diedel [ Fri May 19, 2006 1:46 pm ]
Post subject: 

Umm ... what? :?

Author:  DarkFlameWolf [ Sun May 28, 2006 3:57 pm ]
Post subject:  Bad flare/colored lighting issue.

Surprised no one has spotted something this obvious. I'm current using a ASUS Geforce 4 Nividia 6800 AGP graphics card with 512 mb ram. (yes, that's correct)
I have a 3000+ AMD Anthlon with 1 gig ram. I just downloaded the latest version of D2-XL from the website of Diedel's and installed it and set up all my rendering options. It works fine except for real-time lighting. Dark levels stay dark when it comes time to use flares or use your headlight or fire off your weapons. Nothing you do seems to 'make' any light to lighten up dark areas/levels. It only serves to make the 'light' areas a bit brighter (but not by much), and the dark areas the same. And yes, whatever toggle flag it is that lets weapons have their own light or whatever is flagged, so that probably isn't the issue. So any tips on fixing this myself or do I have to wait for another release for real-time lighting from weapons/flares/headlights?

Author:  LightWolf [ Fri Jul 12, 2013 10:25 am ]
Post subject:  Re: D2X-XL Bug Reports - MS Windows

Ever since installing Rebirth, D2X-XL has been having music problems. When I start the game, I have to turn the music all the way down to zero, then turn it back on to start the music. If I do that the music won't auto-start on the next level (if I remember right).

Author:  Krom [ Fri Jul 12, 2013 2:25 pm ]
Post subject:  Re: D2X-XL Bug Reports - MS Windows

Don't install rebirth and XL in the same folder.

Author:  karx11erx [ Wed Jul 15, 2015 6:11 am ]
Post subject:  Re: Bad flare/colored lighting issue.

To whom it may concern:

This thread is dead.

D2X-XL has its own forum.

D2X-XL bugs should be reported via the bug tracker of the D2X-XL project on Sourceforge.net.

Author:  Krom [ Wed Jul 15, 2015 6:29 am ]
Post subject:  Re: Bad flare/colored lighting issue.

karx11erx wrote:
...This bug has been fixed a while ago...
I would hope so since the post about it was from May 2006 (a little over 9 years ago)...

Author:  karx11erx [ Tue Aug 04, 2015 8:22 am ]
Post subject:  Re: D2X-XL Bug Reports - MS Windows

Oh my ... lol.

Funny thing is that the exact same issue had surfaced in D2X-XL just a few weeks ago, so I didn't check the post date.

Why not lock this forum area.

Page 65 of 65 All times are UTC-06:00
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/