Page 1 of 65

D2X-XL Bug Reports - MS Windows

Posted: Tue Feb 22, 2005 5:13 pm
by Diedel

D2X-XL Bug Reports - MS Windows

This thread is intended for D2X-XL bug reports for Windows - no suggestions, no questions, no bug reports for other OS's here please.

To put them all neatly together and help me not to forget them, I kindly request everybody to post bug reports for D2X-XL/Windows in this thread.

Please keep this thread clean. In case some issue needs detailled discussion, I will open an extra thread for it.

Thanks :)

Diedel (a.k.a. karx11erx)


Please read the D2X-XL FAQ and the D2X-XL Version History to see whether your problem has already been solved.

Posted: Tue Feb 22, 2005 5:34 pm
by Tyranny
D2x-w32 Redbook:
The D2x-w32 application recognizes audio cds from the CD-ROM drive Descent 2 was originally installed from. However, the original D2x code has a bug where the volume slider no longer functions properly. The CD Volume level is currently at maximum no matter what position the slider is in. On the same note it also doesn't retain that you're using the redbook after you exit the program.

D2x-w32 HUD rendering:
All D2x versions before the D2x-w32 Project began have suffered from this problem and for some reason the issue has never been addressed. When D2 is set to the secondary HUD display (The gray bar across the bottom) the shields guage doesn't render the ship in the middle of the shields. Instead there is a black box covering where the ship should be. Also the AB display is always on empty (black) even when the afterburner is at full (should be red) and there is no animation for the AB increasing (Red bar increases on energy recharge) or AB decreasing (Red bar decreasing on AB drain) as was the case in the original D2.

D2x-w32 Miscellaneous:
I noticed while just goofing around in single player that theres a graphical error where the AI robots suddenly morph into wall textures while being shot at. It's only a quick flash of the texture before they return to looking how they should and it seemed kind of random. I'm not sure if thats a hardware issue on my end or something in the D2x source code that the original developers didn't notice. Likewise I'm not sure if it is something that can be fixed, but I would imagine it could. Just thought I'd mention it here while I'm at it. :)

Really great to see this stuff coming along though.

Posted: Tue Feb 22, 2005 5:44 pm
by Sapphire Wolf
Keyboard Bug: when I turn my ship up/down or left/right, It turns slower than normal/usual.

Posted: Tue Feb 22, 2005 6:30 pm
by Tyranny
uh...yeah, thats informative :roll:

Posted: Tue Feb 22, 2005 7:36 pm
by Diedel

if I have questions, I will create an extra thread for it. ;)

I might have time to look into the issues you have reported next week. The texture bug is something I know and I am afraid I will not be able to fix it.


The turn rate should be about the same as in D2 Win95, I had tested that after limiting turn speed recently. It might be slower than before limiting it though.

I have however found that the forward speed was slightly to slow (38 secs instead of 35.5 secs for 100 standard cubes), and I have fixed that. Ofc, this will increase turn speed for keyboard users as well (for about 3%, and only if the turn speed doesn't fall below the minimum turn speed which is currently 2 secs for 360°).

Posted: Tue Feb 22, 2005 7:41 pm
by Sirius
The aforementioned option to disable damage from friendly fire in multiplayer games. (I don't think you've already done it although I'm pretty sure you planned to...)

Posted: Tue Feb 22, 2005 7:42 pm
by Sirius
Oh, in addition. :) I know it breaks compatibility with standard D2, but since you have access to both D2x and DLE-XP, would it be possible to increase the cube limit, and maybe a few other things? :)

Posted: Wed Feb 23, 2005 12:31 am
by Sirius
Great... just updated D2X and now it crashes after player selection.

Error signature:
AppName: d2x-w32.exe AppVer: ModName: d2x-w32.exe
ModVer: Offset: 00073bf7

If that helps any...

The error report has a ton of information including:

Exception Information
Code: 0xc000001d Flags: 0x00000000
Record: 0x0000000000000000 Address: 0x0000000000473bf7

System Information
Windows NT 5.1 Build: 2600
CPU Vendor Code: 756E6547 - 49656E69 - 6C65746E
CPU Version: 00000683 CPU Feature Code: 0383F9FF
CPU AMD Feature Code: 00B0E824

Module 1
Image Base: 0x00400000 Image Size: 0x00000000
Checksum: 0x00000000 Time Stamp: 0x421bdbb1
Version Information
Signature: 00000000
StrucVer: 00000000
FileVer: (0.0:0.0)
ProdVer: (0.0:0.0)
FlagMask: 00000000
Flags: 00000000
OS: 00000000
FileType: 00000000
SubType: 00000000
FileDate: 00000000:00000000

Not sure if this helps any... but only the most recent version (I think; at least it came from today) causes this problem. There is none on my brother's computer, notably...

Posted: Wed Feb 23, 2005 5:52 am
by Aus-RED-5
Diedel. Let me just say you're the best man! Well done sofar! Love your work, and keep up the good job!
Thanks :)

Now 2 things I've notice in this new update.

1) if you select the mouse as a joy and return to the screen. a bunch of numbers apear when you move the mouse. small bug or whatever. no biggie really.

2) when using my joystick (wingman extreme). the pitch is crazy (up, down, left or right). I can't seem to keep my aim steddy or fly steddy with out it moving so weird. I've turned the settings all the way down and still does it. I've even calibrated in windows and still no good. Nothing is wrong with my stick coz it works fine in the older versions or d2x-w32. (I've test it)
I know you changed some stuff having to do with turn rates and so on, but now it seems alot worse then before. Might be just me? I don't know, but before this updated version it was working smooth!
Thats all I have sofar.
Thanks again!

Posted: Wed Feb 23, 2005 8:34 am
by Diedel

there is an edit button you can use to expand posts if you add more stuff.

Disabling friendly fire is next on my todo list.

I have thought of increasing certain limits myself already. I have also thought of allowing 16 players per mine; this would however render D2X-W32 incompatible to standard D2 netgames.

Crash? D'oh! :oops:


joystick handling seems to be problematic. I will have to test this myself again, but I wonder whether different joystick models/drivers deliver vastly different data to Windows/SDL/D2X-W32.

The controls do not work very well current online version of D2X-W32, I know that already. Has to do something with trying to fix the forward speed bug. I am working on this already. When I'm done, the funny numbers will have disappeared, too, I promise. ;)

Posted: Wed Feb 23, 2005 9:30 am
by pipsqueak10
Oops, I get no joystick movement at all. Keyboard works fine but when I try to use the joystick I get no response whatsoever. I've downloaded all your versions and I noticed the joystick wouldn't work with several newer versions but the the joystick would start working again as soon as I downloaded another updated version.

Posted: Wed Feb 23, 2005 11:23 am
by Diedel

re: Cockpit bug

D2X doesn't support a cockpit view ... at least not the version I have and the one mine is based on (0.2.6). Can you please explain how you make a cockpit visible in d2x-w32? Is there a trick?


try to save your player files somewhere else and create a new player file. Adding new menu toggles can affect player files.

Posted: Wed Feb 23, 2005 1:08 pm
by Tyranny
If you're using the higher resolutions under "Modes w/o cockpit view" or whatever it is the cockpit will not show up. I use the 640x480 resolution under the "Modes with cockpit view" setting. Usually toggling between the + or - keys will bring up the gray bar secondary cockpit version or sometimes F3 will bring it up if you're switching between different resolutions.

Posted: Wed Feb 23, 2005 3:00 pm
by Diedel
Ok, I'll try +/-. F3 should not work, and doesn't for me.

Posted: Wed Feb 23, 2005 3:38 pm
by Sirius
Tried your suggestion Diedel - unfortunately, no change... it just automatically crashes after that.

Edit: :roll: I just installed the newest version and the problem evaporated. Go figure. I wonder whether there was a DLL issue or something - I've noticed SDL.dll changing in size between versions a lot.

Posted: Wed Feb 23, 2005 4:30 pm
by Tyranny
I probably need to stick with a set terminology. What I'm speaking of is really more of a HUD then anything. I hope I'm not confusing you with the original "cockpit" that Descent originally defaulted to. I'd hope nobody used that playing online or even SP for that matter :P

Also, is there a way for you to bind the "prtscrn" key to take screenshots? I've noticed D2x won't capture screenshots anymore. The original D1 and D2 had issues with that. You had to uncheck a certain attribute in both executables "properties" in windows. That was with win98 though, not sure how you would do it in XP, if you can at all.

Posted: Wed Feb 23, 2005 5:20 pm
by Diedel
You can use Fraps for screenies, there's a free demo version available.

There's different HUDs: One is like a view from inside a cockpit, the other one is that bar at the screen bottom with colored "icons", the third is the simple text HUD. You refer to the second I've understood.


There is a new version of d2x-w32 available as of now, fixing problems with joystick usage introduced when fixing the speed bug. That version allows to set a dead zone for the joystick with the command line argument "-joydeadzone XX" where XX is the percentage of the maximum value range of the joystick data. E.g. "-joystick 20" means 20% dead zone.

Have fun. ;)

Posted: Wed Feb 23, 2005 6:56 pm
by Sirius
To my experience, taking screenshots in D2x works the same way as taking screenshots in standard Windows.

Posted: Thu Feb 24, 2005 1:55 am
by Sirius
Actually the crash bug is still there; it is just postponed until after you start a level (it crashes out just before anything is displayed, much the same as what DarkFalcon reported).

BUT... I have found a workaround and figured out why it does this.

It only crashes when I use joystick pilots. If I create a keyboard pilot, then switch controllers to joystick in-game it doesn't detect it; however, when I restart D2x it crashes upon level start.

However, if I use mouse or keyboard, there is no problem. This solution is obviously unacceptable though...

The joystick I use is a USB Sidewinder Precision 2, just for reference. I suspect the changes you've made to joystick handling recently may have introduced the problem somehow...

Edit: In addition, I notice d2x_w32 doesn't terminate itself properly on exit; even when it doesn't crash I still see 'd2x_w32.exe' in the task list after exiting...

Posted: Thu Feb 24, 2005 2:34 pm
by Avder
I'm not sure if this has been done yet in d2x, but it might be useful if you madified the ipx game joining code in such a way as to bypass the kali "quickjoin" system that ends up causing temporary desynchs between players when a new player joins the game (EG: players 1 and 2 battle for 15 minutes and they are in synch with eachother item-balance wise and then player 3 joins and all the items are in their original location for him, causing an imbalance and desynch of items until the duplicate items are gradually eliminated by the native d2 code).

Also, there are some levels in which mercury missiles just seem to vanish completely and never respawn. Dunno if thats been fixed but it would be nice....

Posted: Thu Feb 24, 2005 4:24 pm
by Tyranny
The vanishing missile issue is usually caused by an extra cube or cubes in the level architecture that are inaccessible to the players. Theres really not much that can be done about that. Happens a lot with tricky secret rooms or just added features to the level such as wall fan spaces etc...

The other thing you brought up might render netplay on Kali nonfunctional. Which in this case would really suck considering Diedel just fixed it :P Thats only just my opinion, he'll get back to that when he gets back from his trip.

Posted: Thu Feb 24, 2005 6:38 pm
by Sirius
Don't know what happened to Kali making that optional. Screwed stuff up.

Posted: Thu Feb 24, 2005 9:19 pm
by pipsqueak10
Maybe on the next update my comp wont crash on loading D2. With each other update the joy works then doesn't work, the comp crashes then doesn't crash. Although it doesn't really look likes it going to make a difference. I keep checking Kali at all hours of the day and I just don't see any body playing D2 at all.

Posted: Thu Feb 24, 2005 9:32 pm
by Sirius
D2x games aren't detected by Kali.

Posted: Thu Feb 24, 2005 11:47 pm
by pipsqueak10
Maybe I missed something then. I saw in another thread that not seeing d2x games on Kali was fixed.

Posted: Fri Feb 25, 2005 1:06 am
by Sirius
Oh. No, that's a different thing; you can detect them in-game, but in the master game list Kali only seems to show one game when I know there are more than that going on.

Posted: Sun Feb 27, 2005 1:47 am
by Aus-RED-5
I'll try to explain what happen as best as I can.

Got 3 people together to play some D2 on kali.
Me and one other had the new w32 version and the person hosting had the d2 v1.2 vertigo. (all 3 have the vertigo version installed)

soon after the wepons started disappering or become traped between cubes. You could see them there but you wouldn't be able to pick them up. Even sometime fly up to them and it would disapper and then its there again. ... 0027oe.jpg After a while you soon don't have much to fight with.

I also notice when you shoot any missile, the disappering animation comes out just after the missile. ... 0019bo.jpg
So now what??? Anybody else try this and get the same thing?

Posted: Sun Feb 27, 2005 1:43 pm
by Diedel

Do the powerups disappear or get inaccessible when all ppl use d2x-w32? If not, there is probably a difference between some object data representation in D2 "classic" and d2x-w32, much like the one causing d2x-w32 net games not to be detected by other D2 versions and vice versa.


the joystick handling fixes cannot possibly cause the crash. Actually, I just fixed some code already in d2x.

You can try to delete your player files and create a new player. I'd like to have one of your player files causing the crash.

Btw, I can start d2x-w32 and any game with it while using a joystick player file.

Posted: Sun Feb 27, 2005 3:10 pm
by Tyranny
Descent is notorious for having problems handling USB devices IMO. Whatever joystick problems are in the code, I don't think they're a result of whatever Diedel has done. The D2x code to begin with was inferior handling joysticks then even the original D2 was. Diedel has made far bigger strides in correcting joystick handling since he took over the project as far as I'm concerned.

However this does not mean a problem does not exist.
Sirius wrote:Edit: In addition, I notice d2x_w32 doesn't terminate itself properly on exit; even when it doesn't crash I still see 'd2x_w32.exe' in the task list after exiting...
This is something I've noticed with all X versions of descent. Even D1x suffers from this problem. It might not be easily corrected though. It seems to me that it could possibly be a Windows issue in handling older games. Not only that but we're dealing with 10 and 9 year old software respectively that have been modified to suit modern operation. wowexec.exe periodically hangs when these apps don't close out as well. I'm wondering if there is something Descent or Windows is failing to do in closing out the programs.

Posted: Sun Feb 27, 2005 3:27 pm
by Diedel
Update on a few feature requests:

1) Caps Lock

(-> Jesus Freak) Caps Lock is handled by the SDL and cannot be convert to "regular" key behaviour, i.e. deliver "key pressed" signals until released. (Well, it could, but I am not going to fiddle with SDL code).

2) Redbook Audio Volume

(-> Tyr) Redbook Audio is handled by the SDL. Obviously there is no Redbook Audio Volume Control implemented in the SDL, so I have completely disabled the Redbook Audio Volume Control in d2x-w32.

3) HUD Problems

(-> Tyr) Currently investigating.

4) Dual Joysticks

(-> Ferno) Currently investigating.

5) Digital/USB Joysticks

I don't have any problems with my USB joystick and d2x-w32. Generally, you cannot compare D2 "classic" device handling to d2x device handling, as the latter is completely done by the up-to-date SDL.

6) Game crashes

Actually I wonder whether some of the problems with d2x-w32 might be caused by some general operating system instability, e.g. due to old video drivers not having been uninstalled before installing a driver update or so. Not sure about this, but that could well be a reason.

Posted: Sun Feb 27, 2005 3:32 pm
by Tyranny
You disabled the redbook completely? or will it still play an audio CD? I liked that feature of D2...

Posted: Sun Feb 27, 2005 3:33 pm
by Diedel
Tyranny wrote:You disabled the redbook completely? or will it still play an audio CD? I liked that feature of D2...
Read my post over. ;)

Posted: Sun Feb 27, 2005 6:17 pm
by Sapphire Wolf
I found a bug: With the Keyboard, It won't let me fire a flare(by pressing the F Key)

Posted: Sun Feb 27, 2005 6:22 pm
by Duper
Tyranny wrote:You disabled the redbook completely? or will it still play an audio CD? I liked that feature of D2...
one simple fix if you like, burn off the songs to a CD and pop it in while you're playing. It's not synced with the levels, but you get to hear it. as for me, it won't play in D2 win95 either as it doesn't seem to like or care about my SB Live 5.1 and its CD cable. *shrug* I don't listen to music when I play anyways.

Posted: Sun Feb 27, 2005 6:23 pm
by Duper
Dark Falcon wrote:I found a bug: With the Keyboard, It won't let me fire a flare(by pressing the F Key)
Simple question. Do you have it assigned correctly both in D2 options and Dx options?
I don't use the W32 version as the sound is bad. It seems to be related to the sdl. I us and older version of the sdl and the d2x-gl.exe.

The movies and menus look like 256 color format but the game is texture smoothed, sound is great and runs fine. :)

Posted: Sun Feb 27, 2005 7:03 pm
by Sapphire Wolf
okay, maybe its just me.

Posted: Sun Feb 27, 2005 10:05 pm
by zapp
I can't even get D2x-w32 to start, crashes back to the desktop. I have D2X-gl working fine. I took that directory and copied it, then put all the files from D2X-w32 in the new dir (replaced SDL.dll w/ the one included).
I have XP SP2, D2 1.2 Vertigo, ATI Radeon 9800 pro.

Why would D2X work and not D2x-w32? Should I do a fresh install of D2, patch it and then try D2X-w32?

Posted: Sun Feb 27, 2005 10:48 pm
by Sapphire Wolf
zapp wrote: Should I do a fresh install of D2, patch it and then try D2X-w32?
I did that before.

Posted: Sun Feb 27, 2005 11:16 pm
by Garak
zapp wrote:I can't even get D2x-w32 to start, crashes back to the desktop. I have D2X-gl working fine. I took that directory and copied it, then put all the files from D2X-w32 in the new dir (replaced SDL.dll w/ the one included).
I have XP SP2, D2 1.2 Vertigo, ATI Radeon 9800 pro.

Why would D2X work and not D2x-w32? Should I do a fresh install of D2, patch it and then try D2X-w32?
You got the msvcr71.dll ( i think thats the right dll)?
You need it and the sdl.dll to run d2x. Are there any kind of error messages?

Posted: Sun Feb 27, 2005 11:44 pm
by Tyranny
Yeah, that windows needs to terminate the application. I'm getting the same thing with the last release as well.
zapp wrote:Why would D2X work and not D2x-w32? Should I do a fresh install of D2, patch it and then try D2X-w32?
zapp: It's a work in progress. I wouldn't bother re-installing everything just to try to make it work. I don't think it's necessary. If you have a working D2X-gl then make sure that everything that IS working is backed up while you're trying to use D2x-w32. Any feedback Diedel can get will only serve to make the program better. Hopefully he'll get to the bottom of why each release is so inconsistent...