DescentBB
http://www.descentbb.net/

Linux OpenGL problem
http://www.descentbb.net/viewtopic.php?f=6&t=146
Page 1 of 1

Author:  Kevin Bentley [ Sat Feb 14, 2004 4:30 pm ]
Post subject:  Linux OpenGL problem

I'll admit, my experience with Linux and opengl isn't that great.

I've been working on the 1.5 patch for Linux, and so far everything is working ok, but I don't get textures inside the game. I have this problem with the Loki CD install, and the version I built myself.

I was wondering if anyone else has experienced this problem. I'm not sure if it is a driver incompatibility, or something I installed wrong. I know I've got the nvidia X server running because I get the nvidia logo when X starts.

I've got a old TNT card in this box, and I downloaded the latest driver from NVIDIA. I'm about to try a different video card, but I thought I'd ask around first.

Thanks!

Kevin

Author:  Topher [ Sat Feb 14, 2004 6:55 pm ]
Post subject: 

...does glGetError return anything after one pass of rendering?
Sounds like it's not generating texture ID's correctly (glGenTextures is returning 0 or not getting called).

If glGenTextures is returning correct IDs, then try creating the textures each frame (using glTexImage2D). It may be a memory access issue where textures work for the first frame, but OpenGL can no longer access the imade data after that. (A strange problem, but something like it happened when trying to use textures in OpenGL in MFC)

Author:  Kevin Bentley [ Sat Feb 14, 2004 8:13 pm ]
Post subject: 

Since even the 'right off the CD' Loki version has the same problem, I think it is a problem with my driver or setup, not with the actual rendering code in the game.

Author:  Shiva [ Sat Feb 14, 2004 10:04 pm ]
Post subject: 

I never ran D3 on Linux as a client so I can't give you any insightful comments. However there is one fairly easy thing you can do to make sure nothing funny is going on in the Descent 3 code on start-up. That is download Valgrind, it's a kick-ass fault checker/memory leak detector for Linux. You don't have to do anything with the build process except compile with debug symbols. Then run:

valgrind main .....

that's it. It will be slow, but let it sit and see what comes out. You may find something, you might not find anything... All I know is from previous experience, that something can be working like clockwork, change something slightly either inside a program, or it's environment, and it fails because of some dumb bug that went undetected for so long (like for example a Uninitialized memory read).

Author:  Delkian [ Sun Feb 15, 2004 8:43 am ]
Post subject: 

I got something like that - no textures at all - with the DRI drivers for Radeon, but ATI's proprietary drivers work.

As of NVidia, when I had a (working) NVidia card I didn't have Loki D3 yet, and now that I have Loki D3 I don't have a working NVidia card. I may get a GeForce 2 running in a few days, though, and if I can help in any way, I'll be glad to.

I know next to nothing about *nix programming, though, and nothing about OpenGL, so...

Edit:
I did try the demo of Loki D3 once with the NVidia card, though, and it worked.

Author:  Kyouryuu [ Sun Feb 15, 2004 3:20 pm ]
Post subject: 

On an ATI Radeon 9700 using the hacked ATI drivers for XFree 4.3 from Schneider Digital, I saw textures under OpenGL in Descent 3, but noticed instances of "dropped pixels."

What I mean by that is the following. After I would play Descent 3 for a short while (say, one single-player level), I would notice that one color would suddenly be missing in all textures that used that color. Where the color would be was a transparent speck instead. For example, in one instance, the brown of the slanted "construction stripe" texture was missing, and therefore in every place in a level where that texture was, you could see outside the level into the void. In other textures where that shade of brown appeared, the same thing would happen. If I recall correctly, the texture was still treated as solid however. It's not like you could escape or shoot out through these holes.

The problem would get worse as the game continued, with more colors being "dropped."

Author:  Kevin Bentley [ Fri Feb 20, 2004 9:37 pm ]
Post subject: 

Problem solved...a different nvidia video card works fine. I think the previous card was just bad (it came from a pile of old hardware I had, and I don't remember what the deal with it was).

Author:  ccb056 [ Fri Feb 20, 2004 9:45 pm ]
Post subject: 

I have used two different TNT2 cards on two different windows xp installs

When I use OpenGL w/ NVidia's new drivers, no textures, however, it works with direct3d

The problem seemed to have started with the new nvidia drivers because I could see textures in opengl w/ older drivers

Page 1 of 1 All times are UTC-06:00
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/