Introducing Descent3 installation program (TESTERS WANTED!)

For all coding issues - MODers and programmers, HTML and more.

Moderators: Jeff250, fliptw

Post Reply
D.Cent
DBB Ace
DBB Ace
Posts: 53
Joined: Wed Nov 22, 2006 1:50 pm
Location: Schwieberdingen (Germany)
Contact:

Introducing Descent3 installation program (TESTERS WANTED!)

Post by D.Cent » Thu Dec 10, 2009 3:02 pm

As discussed in http://descentbb.net/viewtopic.php?t=16239&start=30 I am working on a program that can replace and extend the normal Descent3 setup program (setup.exe on your Descent3 CD-ROMs).

This is needed since the normal installer doesn't work on Windows Vista / Windows 7 anymore.

Some screenshots i have so far:
Windows XP: http://www.odf-online.org/temp_download ... indows.png
Windows Vista: http://www.odf-online.org/temp_download ... _vista.png
Windows 7: http://www.odf-online.org/temp_download ... r_win7.png
Linux: http://www.odf-online.org/temp_download ... taller.png

So, as you can see, it is cross-platform.

Currently, everything is working except for patching to 1.5, which will be implemented when Kevin makes the release.

The program will be released under GPL v3, which means it will be open source.

The program shall make it possible to install d3 on Linux from a Windows CD and vice versa.

Unfortunately, there is still a problem:
Since Descent3 was sold by many different resellers and was sold in different CD boxes, I can't make sure the program works with every CD.

I think D3 was always sold on 2 CDs, and all contain the same installation program, so the structure for the needed files is equal. To make sure it is working, I'd like to find some testers.

If you're interested, send me a PM - It doesn't matter which platform you're running (except for Mac :-/ ).
Any volunteers?
User avatar
Xamindar
DBB Admiral
DBB Admiral
Posts: 1497
Joined: Sun Jun 06, 2004 2:44 am
Location: California
Contact:

Post by Xamindar » Thu Dec 10, 2009 4:05 pm

I'll try the linux one.....just gotta wait for that 1.5 patch eh? Does it work with the linux installation cds or the windows ones? I have both.
Why doesn't it work?
D.Cent
DBB Ace
DBB Ace
Posts: 53
Joined: Wed Nov 22, 2006 1:50 pm
Location: Schwieberdingen (Germany)
Contact:

Post by D.Cent » Fri Dec 11, 2009 6:35 am

Thanks! It actually works with both, but it's better to use the Linux CDs. Unfortunately you will have to wait for 1.5 before you can do anything with the installation - so you can just delete it if you like.

Which Linux are you running (distribution name and version)?
User avatar
Xamindar
DBB Admiral
DBB Admiral
Posts: 1497
Joined: Sun Jun 06, 2004 2:44 am
Location: California
Contact:

Post by Xamindar » Fri Dec 11, 2009 11:34 am

Gentoo (amd64 build), fully up to date. I currently have D3 working fine on it so it should be a good place to test the 1.5 patch. I'll move my current installation somewhere safe then install a new one to test.
Why doesn't it work?
Post Reply