Page 1 of 1

[MIME types?] Not sure what I did but it works

Posted: Thu Feb 28, 2013 1:00 am
by Isaac
edit: The point of this was to make gedit open files with the correct code coloring for specific file types, like cgi, template, and x. And it works.

I followed this very short "how-to"... ... &Itemid=59

I had to edit /usr/share/mime/packages/ and add some globby looking stuff. I ran a command I've never seen before, "sudo update-mime-database /usr/share/mime". And now my cgi and custom extensions open with the correct coloring in gedit, my gui text editor of choice. I made .cgi be a python file and .template and .x be html files.

Not sure what any of that had to do with gedit, but it works. Why wasn't this a setting within gedit, I'll never know. I guess this is a system-wide change I've made, that will effect my vim editor too.