WHy won't the AMD video drivers install? SOLVED

For system help, all hardware / software topics NOTE: use Coders Corner for all coders topics.

Moderators: Krom, Grendel

Post Reply
User avatar
Posts: 9495
Joined: Thu Nov 05, 1998 12:01 pm
Location: Capital Of Canada

WHy won't the AMD video drivers install? SOLVED

Post by CDN_Merlin » Mon Jul 07, 2014 5:21 pm

Have...to...remember.... to TURN OFF ANTI-VIRUS. ARGH. ONce I did that drivers installed without a hitch.

So I've updated my video card to a Sapphire R9-270x. My old one died with beep codes so I couldn't uninstall the drivers.

I installed the card and booted. Uninstalled the current drivers, rebooted and deleted the AMD folders.
I installed the latest driver package from AMD.
It ended with errors. The one error is that the video drivers failed to install.

I've tried manually updating them and it comes up with an error about timing out.
I've tried checking my BIOS (P8P 67LE) and can't find anything in there that would hinder it.

I've googled this to no end. Everything I've seen on the web I've either tried or hasn't worked.

Running Win 7 64bit and I'm getting frustrated. I would rather not have to re-install to get this working if need be.

Any help appreciated.

Beta tested:
Game Stock Car 2012, Diablo 3, Descent 3 1.5 Patch, C&C Generals, Independance War 2, Starfleet Command 2, Settlers IV,Tzar, Allegiance, Starfleet Command, MAX 2, Defiance
ASUS Z170-P, Core I7-6700K, Coolermaster Hyper 212 EVO CPU Cooler, Gigabyte GF GTX970 OC 4GB GDDR5,Crucial 16GB 2133MHz DDR4, Samsung 850 EVO 250GB 2.5" SATA3 SSD, WD Black 1 TB, ASUS DVD Burner, ASUS 27" Monitor, Fractal Design R5 Mid-Tower Case, Thermaltake ToughPower Gold 750 Watt, Win 10 64Bit
Post Reply